Modify

Opened 4 years ago

Closed 4 years ago

#7120 closed defect (invalid)

TypeError: 'NoneType' object is not iterable

Reported by: StefanSimroth Owned by: martin_s
Priority: normal Component: ExternalLinksNewWindowPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

After installing in Trac 0.11.7 on Apache/Linux, it does not work (links still open in same window/tab).

On a new wiki page request, I get this entry in my trac.log:

2010-05-13 17:03:33,038 Trac[main] DEBUG: Dispatching <Request "GET u'/chrome/tracextlinksnewwindow/extlinks.js'">
2010-05-13 17:03:33,041 Trac[chrome] DEBUG: Prepare chrome data for request

2010-05-13 17:03:33,050 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/trac/web/chrome.py", line 398, in process_request
    in provider.get_htdocs_dirs() if dir[0] == prefix]:
TypeError: 'NoneType' object is not iterable

I already changed the plugin.py file the get_htdocs_dir function to return "tracextlinksnewwindow" instead of "extlinksnewwindow", because I thought that was the problem, but it wasn't.

This renders the plugin unusable for me.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by StefanSimroth

  • Resolution set to invalid
  • Status changed from new to closed

Sorry, after hours of debugging, I found out that this is not an issue with this specific plugin. It's working for me now very well.

The issue was caused by another plugin that did not return anything in the method, where it should have returned at least an empty array.

I filed a ticket at the main Trac instead: http://trac.edgewall.org/ticket/9342

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.