Modify

Opened 4 years ago

Closed 4 years ago

Last modified 23 months ago

#7165 closed defect (invalid)

Installation fails with postgres 8.4.4

Reported by: henrik.steensland@… Owned by: bart
Priority: high Component: BacklogPlugin
Severity: critical Keywords: postgresql backup environment upgrade
Cc: Trac Release: 0.11

Description (last modified by rjollos)

When activating the plugin, the message TracError: The Trac Environment needs to be upgraded. is shown.

However, such an upgrade fails with:

Command failed: Backup attempt failed (/usr/lib/postgresql/8.4/bin/pg_dump: invalid option -- 'd'
Try "pg_dump --help" for more information.

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 4 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

Actually, the problem is in trac 0.11.5 itself.
The following patch solved the problem.

/usr/lib/python2.6/dist-packages/trac/db$ diff postgres_backend.py.org postgres_backend.py

117c117
<         args = [self.pg_dump_path, '-C', '-d', '-x', '-Z', '8']
---
>         args = [self.pg_dump_path, '-C', '-x', '-Z', '8']

comment:2 Changed 4 years ago by henrik.steensland@…

The above anonymous post was from me. Plugin works fine.

comment:3 Changed 23 months ago by rjollos

  • Description modified (diff)

comment:4 Changed 23 months ago by rjollos

  • Keywords postgresql backup environment upgrade added

comment:5 in reply to: ↑ 1 Changed 23 months ago by rjollos

Replying to anonymous:

Actually, the problem is in trac 0.11.5 itself.

See t:#8759 for more details.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from bart. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.