Modify

Opened 5 years ago

Closed 5 years ago

#7202 closed enhancement (fixed)

Python 2.4 support

Reported by: pipern Owned by: mrelbe
Priority: normal Component: TracTicketChangesetsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

In order to support Python 2.4, I did this:

diff --git a/ticketchangesets/admin.py b/ticketchangesets/admin.py
index f068b11..0ea8a14 100755
@@ -28,8 +28,8 @@ from trac.admin import IAdminCommandProvider
 from trac.core import *
 from trac.util.text import printout
 
-from .api import *
-from .commit_updater import *
+from ticketchangesets.api import *
+from ticketchangesets.commit_updater import *
 
 class TicketChangesetsAdmin(Component):
     """trac-admin command provider for ticketchangesets plugin."""
diff --git a/ticketchangesets/db/db1.py b/ticketchangesets/db/db1.py
index 957a4e8..dbaee29 100755
@@ -24,8 +24,8 @@
 
 from trac.db import *
 
-from ..api import *
-from ..commit_updater import *
+from ticketchangesets.api import *
+from ticketchangesets.commit_updater import *
 
 ##
 ## Database schema

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by mrelbe

(In [8080]) Support Python 2.4, see #7202.

Thanks to "pipern" for the patch.

comment:2 Changed 5 years ago by mrelbe

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain mrelbe.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.