Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7220 closed defect (invalid)

locale not found error because of (wrong: typo in setup.py) missing compilation before egg build

Reported by: anonymous Owned by: hasienda
Priority: high Component: WikiTicketCalendarMacro
Severity: major Keywords: locale compile_catalog
Cc: rjollos Trac Release: 0.12

Description

in setup.py

I had to change:
'locale/*/LC_MESSAGS/*.mo'

in:
'locale/*/LC_MESSAGS/*.po'

else I got an error complaining about missing wikiticketcalendar/locale

the ticket system was complaining about keyword "MESSAG3", so i could not post this BUG.
is that another bug?

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by rjollos

  • Owner changed from rjollos to hasienda

Reassigning to hasienda, who has been doing the development.

comment:2 Changed 4 years ago by hasienda

  • Cc rjollos added
  • Keywords compile_catalog added; wikiticketcalendar/locale removed
  • Resolution set to invalid
  • Severity changed from normal to major
  • Status changed from new to closed
  • Summary changed from locale not found error because of typo in setup.py to locale not found error because of (wrong: typo in setup.py) missing compilation before egg build

This is not a bug, this is the feature.

Did you try with you modification? Certainly not. Think twice, please: PO files are verbatim translations for development, but MO are what gettext will use in the end. If you get an error complaining about missing locale dir, this is only for the fact, that you missed to actually compile any catalog with

python ./setup.py compile_catalog

before you make the egg. With a PO in your egg you'd never see any translated text. So the error is correct, your complaint and proposed solution is invalid.

However I'll happily accept a documentation bug against the wiki page, because I did give no pointer for novice in the field of i18n/l10n.

Sorry for the inconvenience, documentation will be improved instantly.

comment:3 Changed 4 years ago by hasienda

Done, see current wiki page for WikiTicketCalendarMacro.

comment:4 Changed 4 years ago by CuriousCurmudgeon

(In [9370]) refs #7220

  • For consistency I handled this in the same way queries do. The dropdown will still show $USER, but it will be replaced with the current user when actually modifying the ticket.

comment:5 Changed 4 years ago by CuriousCurmudgeon

Please ignore the above. I put the wrong ticket number in my commit message. Should have been #7720. :(

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.