Modify

Opened 4 years ago

Closed 23 months ago

#7261 closed enhancement (duplicate)

include plugin external site authentication

Reported by: anonymous Owned by: rjollos
Priority: normal Component: IncludeMacro
Severity: normal Keywords: remote authentication
Cc: Trac Release: 0.11

Description

Hy,

is it possible to include external webpages in trac with the include plugin when it it is username and password secured. How is the syntax, something like below?

Include(http://PageNamexy)(username:namexy)(password:passwordxy?

Thanks a lot

David

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by anonymous

So what is the syntax like???I'm lookinf forward to it.

comment:2 Changed 4 years ago by osimons

Have you tried the standard way of http://user:passwd@www.example.com/? That is only part of the standard for 'plain' browser authentication, and won't work if you for instance use forms-based authentication.

comment:3 Changed 4 years ago by anonymous

For sure, but it brings up "Unsupported include source user:passwd@http://192.168.1.1"

comment:4 Changed 4 years ago by anonymous

There is an <embed>, <object> tag in combination with "render_unsafe_content" option and also the include plugin. But none of them supports apache basic auth, or am I wrong?

comment:5 Changed 23 months ago by hasienda

  • Keywords remote authentication added
  • Owner changed from coderanger to rjollos
  • Priority changed from high to normal
  • Type changed from defect to enhancement

comment:6 Changed 23 months ago by hasienda

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #6879.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.