Modify

Opened 4 years ago

Closed 4 years ago

#7268 closed defect (worksforme)

gitplugin for 0.12 doesn't work/install

Reported by: anonymous Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: peter@… Trac Release: 0.12

Description

i got two syntax error when it install using by easy_install. please see log below

[root@localhost conf]# easy_install http://trac-hacks.org/svn/gitplugin/0.12

Downloading http://trac-hacks.org/svn/gitplugin/0.12
Doing subversion checkout from http://trac-hacks.org/svn/gitplugin/0.12 to /tmp/easy_install-OiOehN/0.12
Processing 0.12
Running setup.py -q bdist_egg --dist-dir /tmp/easy_install-OiOehN/0.12/egg-dist-tmp-zSsp-c

File "build/bdist.linux-i686/egg/tracext/git/PyGIT.py", line 89

with self.lock:


SyntaxError: invalid syntax

File "build/bdist.linux-i686/egg/tracext/git/git_fs.py", line 391

yield (self.path, rev, Changeset.EDIT if not is_last else Changeset.ADD)


SyntaxError: invalid syntax
warning: install_data: setup script did not provide a directory for 'COPYING' -- installing right in 'build/bdist.linux-i686/egg'
warning: install_data: setup script did not provide a directory for 'README' -- installing right in 'build/bdist.linux-i686/egg'
zip_safe flag not set; analyzing archive contents...
TracGit 0.12.0.2dev-r7757 is already the active version in easy-install.pth

Installed /usr/lib/python2.4/site-packages/TracGit-0.12.0.2dev_r7757-py2.4.egg
Processing dependencies for TracGit==0.12.0.2dev-r7757
Finished processing dependencies for TracGit==0.12.0.2dev-r7757

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by anonymous

  • Trac Release changed from 0.11 to 0.12

Worked fine over here

Looks like maybe you need to remove the TracGitPlugin first?

comment:2 Changed 4 years ago by anonymous

I'm getting and I have no TracGitPlugin.

running install
running bdist_egg
running egg_info
writing TracGit.egg-info/PKG-INFO
writing namespace_packages to TracGit.egg-info/namespace_packages.txt
writing top-level names to TracGit.egg-info/top_level.txt
writing dependency_links to TracGit.egg-info/dependency_links.txt
writing entry points to TracGit.egg-info/entry_points.txt
reading manifest file 'TracGit.egg-info/SOURCES.txt'
writing manifest file 'TracGit.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/tracext
creating build/bdist.linux-x86_64/egg/tracext/git
copying build/lib/tracext/git/git_fs.py -> build/bdist.linux-x86_64/egg/tracext/git
copying build/lib/tracext/git/PyGIT.py -> build/bdist.linux-x86_64/egg/tracext/git
copying build/lib/tracext/git/init.py -> build/bdist.linux-x86_64/egg/tracext/git
copying build/lib/tracext/init.py -> build/bdist.linux-x86_64/egg/tracext
byte-compiling build/bdist.linux-x86_64/egg/tracext/git/git_fs.py to git_fs.pyc

File "build/bdist.linux-x86_64/egg/tracext/git/git_fs.py", line 391

yield (self.path, rev, Changeset.EDIT if not is_last else Changeset.ADD)


SyntaxError: invalid syntax
byte-compiling build/bdist.linux-x86_64/egg/tracext/git/PyGIT.py to PyGIT.pyc

File "build/bdist.linux-x86_64/egg/tracext/git/PyGIT.py", line 89

with self.lock:


SyntaxError: invalid syntax
byte-compiling build/bdist.linux-x86_64/egg/tracext/git/init.py to init.pyc
byte-compiling build/bdist.linux-x86_64/egg/tracext/init.py to init.pyc
installing package data to build/bdist.linux-x86_64/egg
running install_data
warning: install_data: setup script did not provide a directory for 'COPYING' -- installing right in 'build/bdist.linux-x86_64/egg'
copying COPYING -> build/bdist.linux-x86_64/egg
warning: install_data: setup script did not provide a directory for 'README' -- installing right in 'build/bdist.linux-x86_64/egg'
copying README -> build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/EGG-INFO

comment:3 follow-up: Changed 4 years ago by Mkava

  • Summary changed from gitplugin for 0.12 doesn't works and install to gitplugin for 0.12 doesn't work/install

I'm having the same issue. The repos I have for my Linux distro (FC 13) only had the trac .11 plugin, so I did the install using easy_install. Here's the output.

Hope this helps resolve the issue.
---
[mkava@home ~]$ sudo easy_install http://trac-hacks.org/svn/gitplugin/0.12
[sudo] password for mkava:
install_dir /usr/lib/python2.6/site-packages/
Downloading http://trac-hacks.org/svn/gitplugin/0.12
Doing subversion checkout from http://trac-hacks.org/svn/gitplugin/0.12 to /tmp/easy_install-bF3zh1/0.12
Processing 0.12
Running setup.py -q bdist_egg --dist-dir /tmp/easy_install-bF3zh1/0.12/egg-dist-tmp-aeiSfp
warning: install_data: setup script did not provide a directory for 'COPYING' -- installing right in 'build/bdist.linux-i686/egg'
warning: install_data: setup script did not provide a directory for 'README' -- installing right in 'build/bdist.linux-i686/egg'
zip_safe flag not set; analyzing archive contents...
TracGit 0.12.0.2dev-r7757 is already the active version in easy-install.pth

Installed /usr/lib/python2.6/site-packages/TracGit-0.12.0.2dev_r7757-py2.6.egg
Processing dependencies for TracGit==0.12.0.2dev-r7757
Finished processing dependencies for TracGit==0.12.0.2dev-r7757

comment:4 in reply to: ↑ 3 Changed 4 years ago by Mkava

Now it works, after I redid the installation once more. :/
When I look at the plugins page, the old plugin would show up, I'd refresh, and the new one would be in its place. Everytime I refreshed this page, the other plugin showed up.

comment:5 Changed 4 years ago by peter@…

  • Cc peter@… added
  • Resolution set to worksforme
  • Status changed from new to closed

I don't know what the problem is with your installation, but it's not a bug in the plugin. The plugin installs fine for me. Please don't use the bug tracker as a support forum. Make sure to ask questions in the right place. I would suggest the [trac-wiki:MailingList Trac mailing list] or the [trac-wiki:IrcChannel IRC channel].

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hvr. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.