Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7320 closed defect (invalid)

Can't get it to work on a Trac 0.12 installation

Reported by: anonymous Owned by: jun66j5
Priority: normal Component: TracWysiwygPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.12

Description

I was using this plugin on Trac 0.11 (it's excellent and extremely useful by the way!) but in order to install a different plugin I had to upgrade Trac to 0.12. The upgrade went smoothly but of course the TracWysiwygPlugin stopped working, prompting complaints from my Trac users :-) After visiting the Trac-Hacks TracWysiwygPlugin page, I saw that a new version of the plugin for Trac 0.12 was available so I installed it using the easy_install method (and the trac.ini entry). The plugin shows up in Admin / Plugins as activated but you don't see any options in the UI - nothing has changed - no wysiwyg radio button etc, nothing. I then tried to repeat the install using the python setup.py install method, but again, though the plugin shows up in Trac Admin as activated, the functionality doesn't appear in the UI. I've checked the Trac.log file for any clues and can find none in there. The install (both ways) seemed to go fine with no errors. I and my Trac users are using IE7 but I've tried with Firefox 3 and it's the same, no UI changes at all, i.e. can't use the plugin functionality.

My apologies if I've done something wrong on the install but any help or troubleshooting advice you can offer would be much appreciated. I and my Trac users really miss the plugin! Many thanks!

Attachments (0)

Change History (15)

comment:1 Changed 4 years ago by anonymous

  • Priority changed from normal to high
  • Severity changed from normal to blocker

comment:2 Changed 4 years ago by jun66j5

Thanks for your try and reports.

Try to force-reload or clear browser cache.
cf. comment:ticket:7306:4

If the plungin doesn't work with the help of it, let me know the pages that it doesn't work.

comment:3 Changed 4 years ago by anonymous

I can confirm this for latest version of TracWysiwygPlugin (SVN r8234) BUT with Trac 0.11.7 under Ubuntu 10.4 LTS.
Same effects as drescribed by reporter of this BUG!
Activated as plugin in Admin-Plugins Page but no stuff when editing pages.. :-(

Pls help out, as we use this in a productive environment.

comment:4 Changed 4 years ago by anonymous

Additionally, i cleared the Browser Cache (FF, 3.6.4), which had absolutely no effect...

comment:5 Changed 4 years ago by anonymous

  • Priority changed from high to highest

comment:6 follow-up: Changed 4 years ago by anonymous

Using Firebug, i found that even though wysiwyg.js is loaded to the clients browser, the JS code from there is never executed when entering Page-Edit mode. Maybe this information may help to solve this issue?

comment:7 in reply to: ↑ 6 Changed 4 years ago by jun66j5

Replying to anonymous:

Using Firebug, i found that even though wysiwyg.js is loaded to the clients browser, the JS code from there is never executed when entering Page-Edit mode. Maybe this information may help to solve this issue?

Please check that wysiwyg-load.js is loaded.
wysiwyg.js only defines TracWysiwyg class and TracWysiwyg executes from wysiwyg-load.js.


I think that some errors of javascript occur by the other plugins.

  1. Check the javascript error console in your browser
  2. Let me know the plugins that you've installed.
  3. Attach the trac.log in your environments to this ticket.
    1. Enable logging and set DEBUG to the log level
    2. Access your trac website with your browser
  4. Try to enable only tracwysiwygplugin and disable the other plugins.

comment:8 Changed 4 years ago by anonymous

1.) Yes, wysiwyg-load.js is loaded to the client side. So both JS Files are available here...

2.) As we have a multi-instance based trac installation, some plugins are enabled for all instances, namely:
IniAdmin 0.2
AutocompleteUsers 0.4.1
TracIncludeMacro 2.1
TracStats 0.3
TracWysiwyg 0.11.0.2

This one is activated only for some of them, so the effect is not caused by it:
WikiCalendarMacro

I will try to look at debug logs and attach trac.log later on this day...

comment:9 Changed 4 years ago by anonymous

UPDATE:
Disabling IniAdmin? 0.2 AutocompleteUsers? 0.4.1 TracIncludeMacro? 2.1 TracStats? 0.3 only leaving TracWysiwyg active DID NOT HELP :-(

comment:10 Changed 4 years ago by anonymous

This should be the main problem (found in console output of Firebug):

jQuery is not defined
[Break on this error] jQuery(document).ready(function($) {
wysiwyg-load.js (line 1)

comment:11 follow-up: Changed 4 years ago by anonymous

OK. Here should be a fix (workaround for this problem - at least on Ubuntu 10.4 LTS):

cd /usr/lib/python2.6/dist-packages/trac/htdocs/js
ln -s /usr/share/javascript/jquery/jquery.js jquery.js

Attention: There is a symlink in "/usr/lib/python2.6/dist-packages/trac/htdocs/js" but it is named "query.js" not "jquery.js". No idea is has the fault for this misbehaviour...

After this it works again for me :-)
@jun66j5: Thanks for quick replies on that issue, GOOD JOB :)

comment:12 Changed 4 years ago by anonymous

  • Priority changed from highest to normal
  • Severity changed from blocker to critical

lowered priority and severity as there seems to be a valid workaround for this issue.

comment:13 in reply to: ↑ 11 Changed 4 years ago by jun66j5

  • Resolution set to invalid
  • Status changed from new to closed

Replying to anonymous:

OK. Here should be a fix (workaround for this problem - at least on Ubuntu 10.4 LTS):

cd /usr/lib/python2.6/dist-packages/trac/htdocs/js
ln -s /usr/share/javascript/jquery/jquery.js jquery.js

Attention: There is a symlink in "/usr/lib/python2.6/dist-packages/trac/htdocs/js" but it is named "query.js" not "jquery.js". No idea is has the fault for this misbehaviour...

After this it works again for me :-)

Good :)

The issue is Trac's installation issue. I close it.

comment:14 follow-up: Changed 4 years ago by josh

Is there or was there a ticket (for Trac itself) on this problem? I just ran into this issue myself. I was able to fix it by making the symlink as described above, but I have to wonder if this is fixed in Trac's install process...

I couldn't find a corresponding Trac ticket on this. Thanks for the fix/workaround!

comment:15 in reply to: ↑ 14 Changed 4 years ago by jun66j5

Replying to josh:

Is there or was there a ticket (for Trac itself) on this problem? I just ran into this issue myself. I was able to fix it by making the symlink as described above, but I have to wonder if this is fixed in Trac's install process...

I couldn't find a corresponding Trac ticket on this. Thanks for the fix/workaround!

I found a similar issue on Ubuntu BTS - Bug #610205 in trac (Ubuntu): “syntax highlighting/pygments is broken (trac is missing a link to jquery.js)”.
I think that it's Debian/Ubuntu package issue.

I hope that it helps you and all trac users.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.