Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7376 closed defect (fixed)

When deleting custom ticket fields with this plugin, the <name>.format line remains

Reported by: dmcr@… Owned by: osimons
Priority: normal Component: CustomFieldAdminPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

Hi,

The CustomFieldAdminPlugin 0.2.2 works well in all respects except that when deleting a plugin it created, it deletes all lines from trac.ini except for <name>.format. I think this should be deleted as well.

There is a 2nd minor problem which could be fixed with documentation if you don't want to change the code: This plugin allows custom field names to begin with a numeric (e.g., 1st_custom_field). Trac silently ignores such fields, and they don't appear in either the new ticket or existing ticket displays.

Finally, there is another minor problem that I cannot reproduce, but thought I should mention it: The first time I used this plugin, and created my first custom field, it was given Order 1. When I created the second custom field, it was also given Order 1. When I checked the drop-down list, I was given a choice of 0 or 1 (same as for the first custom field). When I created the 3rd custom field, it was given Order 3 (drop-down choices were 0,1,2,3 for this and the other two custom fields). So I changed the 2nd custom field from 1 to 2, and I have not seen the problem happen again, even if I delete all custom fields (and the [ticket-custom] header in trac.ini), and start over. I don't usually report non-reproducible problems, but I thought it odd that '0' was always offered as a choice, and might give you a clue as to why this sometimes happens.

Thanks for an otherwise very useful plugin.

Dennis

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by osimons

  • Resolution set to fixed
  • Status changed from new to closed

(In [8261]) CustomFieldAdminPlugin: Now also remove .format option when deleting fields + detect if name does not begin with a character (a-z). Bumped version number.

Fixes #7376. Thanks for report!

comment:2 Changed 4 years ago by osimons

BTW, the last issue has been covered in other reports too (ordering problem). I'm not able to reproduce it anymore, so I'm just going to ignore it... :-|

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.