Modify

Opened 4 years ago

Closed 4 years ago

#7379 closed enhancement (wontfix)

Change TICKET_BATCH_MODIFY permission to BATCH_MODIFY

Reported by: kace25_2000@… Owned by: CuriousCurmudgeon
Priority: normal Component: BatchModifyPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Could the permission for this plugin be changed so the permission name does not include "TICKET". For example change it from "TICKET_BATCH_MODIFY" to just "BATCH_MODIFY".

I would like a way to set permissions for doing batch modify to only certain users. The problem is that currently in Trac the only way to allow a user to delete attachments on a ticket is if they have the TICKET_ADMIN permission. Unfortunately this also gives them the TICET_BATCH_MODIFY permission because TICKET_ADMIN includes TICKET*.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by CuriousCurmudgeon

  • Resolution set to wontfix
  • Status changed from new to closed

I would suggest patching your own version for this. Changing the name of the permission would break with Trac conventions and break the permission for all existing users.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from CuriousCurmudgeon. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.