Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7423 closed defect (invalid)

move_item not defined - problem with javascript

Reported by: andrea.costantini@… Owned by: airadier
Priority: high Component: TracWikiPrintPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

Hello,
I've installed this plugin on a CentOS server using trac with apache.
Single page is working correctly, but when I try to "makebook" from the admin panel, I cannot move pages from "All Pages" to "Selected Pages".
From firefox console error I can see that the problem is with javascript functions, seems that admin_wikiprint.js was not found by the browser.
How can I solve this? Any help is appreciated!
Thanks,
Andrea

System Information
Trac: 0.11.7
Python: 2.4.3 (#1, Sep 3 2009, 15:37:12) [GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools: 0.6c9
MySQL: server: "5.0.77", client: "5.0.77", thread-safe: 1
MySQLdb: 1.2.2
Genshi: 0.5.1
mod_python: 3.2.8
Pygments: 1.3.1
Subversion: 1.6.11 (r934486)
jQuery: 1.2.6

Attachments (0)

Change History (12)

comment:1 Changed 4 years ago by SLamontagne

I simply want to report that I have the exact same problem.

comment:2 Changed 4 years ago by airadier

The file should be accessible on the URL:

/path/to/tracproject/chrome/wikiprint/js/admin_wikiprint.js

I guess it won't work if you try to access this URL from your browser, but could you try anyway?

what are you using? modpython, wsgi?

Thanks.

comment:3 Changed 4 years ago by costpid4

I cannot access the js file through the url. I've tried to remove and reinstall the plugin, after installation I can find admin_wikiprint.js located in
/usr/lib/python2.4/site-packages/tracwikiprintplugin/0.11/build/lib/wikiprint/htdocs/js/
and
/usr/lib/python2.4/site-packages/tracwikiprintplugin/0.11/wikiprint/htdocs/js/
is it correct?

I use apache with modpython...

comment:4 Changed 4 years ago by costpid4

Another hint: if I try to access directly http://x.x.x.x/trac/project/chrome/wikiprint/js/admin_wikiprint.js from the browser, error is: AttributeError: 'TicketStatsPlugin' object has no attribute 'get_htdocs_dirs'. If I disable TicketStatsPlugin js file work fine!

comment:5 Changed 4 years ago by rjollos

Which version of the TracTicketStatsPlugin do you have installed? The get_htdocs_dir issue was fixes in #4052.

comment:6 follow-ups: Changed 4 years ago by airadier

  • Status changed from new to assigned

Thanks rjollos and costpid4, it looks like TracTicketStatsPlugin might be preventing other plugins, like WikiPrint, to register their own htdocs directory.

Can you confirm if this is fixed with the latest version of TicketStatsPlugin?

Thanks.

comment:7 in reply to: ↑ 6 Changed 4 years ago by rjollos

Replying to airadier:

Thanks rjollos and costpid4, it looks like TracTicketStatsPlugin might be preventing other plugins, like WikiPrint, to register their own htdocs directory.

I was testing out the TracTicketStatsPlugin just last weekend and confirmed that it was working correctly. The issue was fixed in [6379], which closed 3 duplicate bug reports, see comment:2:ticket:4052.

comment:8 in reply to: ↑ 6 Changed 4 years ago by anonymous

Replying to airadier:

Can you confirm if this is fixed with the latest version of TicketStatsPlugin?

Yes, I've upgraded TracTicketStatsPlugin and now your plugin work fine!
Many thanks to everybody for help!
Andrea

comment:9 Changed 4 years ago by costpid4

sorry, I forget to login into previous post...

comment:10 Changed 4 years ago by airadier

  • Resolution set to invalid
  • Status changed from assigned to closed

Ok, so if SLamontagne and andrea.costantini (or is it costpid4?) can confirm it too, I'm keeping the ticket as invalid, so it's visible if others find the same problem.

Thanks for your help.

comment:11 Changed 4 years ago by costpid4

Yes, I am, I have open the ticket before registering my account...

comment:12 in reply to: ↑ 6 Changed 4 years ago by rjollos

Replying to airadier:

Can you confirm if this is fixed with the latest version of TicketStatsPlugin?

Ahhh. Misread your question ... in comment:7 thought you were asking about being fixed in TracTicketStatsPlugin, not fixed in particular installation after an upgrade ... but glad this issue is resolved anyway.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.