Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#7429 closed defect (invalid)

Supposed license issue prevent integration in "official" trac

Reported by: anonymous Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords: license issue
Cc: Trac Release: 0.11

Description

http://trac.edgewall.org/wiki/SeaChange/WhatDevelopersWant §5 says:

Note that some plugins will never be integrated or even bundled, due to licensing issues
and gittrac is given as an example.

What is this license issue ?
Can it be solved ?

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by hvr

As far as the code I've written is concerned, I've got no issues changing the licence to whatever the Trac project requires, if it helps keeping the git plugin better maintained :-)

comment:2 Changed 4 years ago by peter@…

  • Resolution set to invalid
  • Status changed from new to closed

My guess is that gittrac refers to something other than this plugin. Also, please don't use tickets to ask general questions. I would suggest posting to the [trac-wiki:MailingList Trac mailing list] instead.

comment:3 Changed 3 years ago by rjollos

It needs to have a BSD license, at least as far as I understand it. I tried to look at whether this was the case, but was blocked by #9807.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.