Modify

Opened 4 years ago

Closed 2 years ago

#7435 closed defect (duplicate)

Doesn't Show Up in Plugins

Reported by: joshk@… Owned by: CuriousCurmudgeon
Priority: normal Component: BatchModifyPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I can place the egg in /var/trac/env/plugins, and/or use the uploader on the admin plugins page, but it doesn't show in the plugin list. I'm on 0.11.1 from Debian Lenny. Python is 2.5.2.

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by anonymous

FWIW the .deb package also doesn't appear to do anything. Maybe something else is wrong on my system?

comment:2 Changed 4 years ago by CuriousCurmudgeon

Take a look at #7123. This might be the same issue. For some reason Debian seems to have problems with the naming of the egg. If renaming the egg does work for you please close this ticket as a duplicate. If you could turn on debug logging and restart Trac that would be great too. I want to see what error message Trac is giving when it tries to load the egg.

comment:3 Changed 4 years ago by anonymous

  • Owner changed from CuriousCurmudgeon to anonymous
  • Status changed from new to assigned

the .deb took effect after restarting apache; but in the name of debugging I have removed that, and gone back and tried the rename. No dice. I will grab a debug log when I don't have a ton of devs hitting the system. ;)

comment:4 Changed 4 years ago by rjollos

  • Owner changed from anonymous to CuriousCurmudgeon
  • Status changed from assigned to new

Looks like the owner of this ticket was accidentally changed.

comment:5 Changed 4 years ago by CuriousCurmudgeon

  • Resolution set to invalid
  • Status changed from new to closed

I haven't heard back in awhile. Since there was no actual problem and I was just waiting for some debug info, I am closing this.

comment:6 Changed 2 years ago by brad103

  • Resolution invalid deleted
  • Status changed from closed to reopened

I can confirm this problem with latest 0.12 just installed via easy_install on debian squeeze with python 2.6. Had to checkout src, modify setup.py, and create egg which ended up as BatchModify-0.8.0_r10978-py2.6.egg.

Previously I'd tried installing the downloaded egg via the admin screen. This would move it into place fine, but never displayed here, nor worked

comment:7 Changed 2 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #7123

Add Comment

Modify Ticket

Action
as closed The owner will remain CuriousCurmudgeon.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.