Modify

Opened 4 years ago

Closed 4 years ago

#7508 closed defect (fixed)

Wrong link to changeset

Reported by: alitrix Owned by: richard
Priority: normal Component: TracTicketChangelogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

The links in the changeset column in the table don't work (red cirkelde). When you click on them, you get:

No repository specified and no default repository configured.

The link in the post (which is generated by trac-admin itself) works fine.

Attachments (1)

screenshot.png (51.4 KB) - added by alitrix 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by alitrix

comment:1 Changed 4 years ago by alitrix

  • Trac Release changed from 0.11 to 0.12

comment:2 in reply to: ↑ description Changed 4 years ago by richard

  • Status changed from new to assigned

What vcs are you using?

comment:3 follow-up: Changed 4 years ago by alitrix

If you mean version of the plugin, then r8367

comment:4 in reply to: ↑ 3 Changed 4 years ago by richard

Replying to alitrix:

If you mean version of the plugin, then r8367

I mean version control system, svn, git or mecurial?

comment:5 Changed 4 years ago by alitrix

In that case, svn.

comment:6 Changed 4 years ago by richard

Maybe new feature of trac's versioncontrol module that has not been tested yet. Could you show your trac detail info, which can be found in about trac?

comment:7 Changed 4 years ago by alitrix

Sure

System Information
Trac 	0.12
Genshi 	0.6
pysqlite 	2.3.2
Python 	2.5.2 (r252:60911, Jan 4 2009, 21:59:32) [GCC 4.3.2]
setuptools 	0.6c12
SQLite 	3.5.9
Subversion 	1.5.1 (r32289)
jQuery:	1.4.2
Installed Plugins
AdvancedTicketWorkflowPlugin 	0.10dev-r7701 	/usr/lib/python2.5/site-packages/AdvancedTicketWorkflowPlugin-0.10dev_r7701-py2.5.egg
ScriptAuth 	0.1 	/usr/lib/python2.5/site-packages/ScriptAuth-0.1-py2.5.egg
TracAccountManager 	0.2.1dev-r7737 	/usr/lib/python2.5/site-packages/TracAccountManager-0.2.1dev_r7737-py2.5.egg
TracDuplicates 	0.1 	/usr/lib/python2.5/site-packages/TracDuplicates-0.1-py2.5.egg
TracTicketChangelogPlugin 	0.1 	/usr/lib/python2.5/site-packages/TracTicketChangelogPlugin-0.1-py2.5.egg
TracVote 	0.1.2 	/usr/lib/python2.5/site-packages/TracVote-0.1.2-py2.5.egg
Configuration
Section 	Name 	Value
account-manager 	account_changes_notify_addresses 	technieknotifications@domain.net
authentication_url 	
force_passwd_change 	true
generated_password_length 	8
hash_method 	HtDigestHashMethod
notify_actions 	new,change,delete
password_file 	/home/trac/gptrac/.htpasswd
password_format 	htpasswd
password_store 	HtPasswdStore,ScriptAuthStore
persistent_sessions 	true
reset_password 	True
script_auth_url 	http://ali.domain/authCorpUser.php?user=<USERNAME>&pass=<PASSWORD>
attachment 	max_size 	10240000
render_unsafe_content 	false
browser 	color_scale 	True
downloadable_paths 	/trunk, /branches/*, /tags/*
hide_properties 	svk:merge
intermediate_color 	
intermediate_point 	
newest_color 	(255, 136, 136)
oldest_color 	(136, 136, 255)
oneliner_properties 	trac:summary
render_unsafe_content 	false
wiki_properties 	trac:description
changeset 	max_diff_bytes 	10000000
max_diff_files 	0
wiki_format_messages 	true
components 	acct_mgr.admin.accountmanageradminpage 	enabled
acct_mgr.api.accountmanager 	enabled
acct_mgr.db.sessionstore 	enabled
acct_mgr.htfile.abstractpasswordfilestore 	disabled
acct_mgr.htfile.htdigeststore 	disabled
acct_mgr.htfile.htpasswdstore 	enabled
acct_mgr.http.httpauthstore 	disabled
acct_mgr.notification.accountchangelistener 	enabled
acct_mgr.notification.accountchangenotificationadminpanel 	enabled
acct_mgr.pwhash.htdigesthashmethod 	enabled
acct_mgr.pwhash.htpasswdhashmethod 	enabled
acct_mgr.svnserve.svnservepasswordstore 	enabled
acct_mgr.web_ui.accountmodule 	enabled
acct_mgr.web_ui.emailverificationmodule 	disabled
acct_mgr.web_ui.loginmodule 	enabled
acct_mgr.web_ui.registrationmodule 	enabled
advancedworkflow.* 	enabled
scriptauth.main.scriptauthstore 	enabled
ticketlog.web_ui.ticketlogmodule 	enabled
trac.versioncontrol.api.repositorymanager 	enabled
trac.versioncontrol.svn_authz.svnauthzoptions 	enabled
trac.versioncontrol.svn_fs.subversionconnector 	enabled
trac.versioncontrol.svn_prop.subversionmergepropertydiffrenderer 	enabled
trac.versioncontrol.svn_prop.subversionmergepropertyrenderer 	enabled
trac.versioncontrol.svn_prop.subversionpropertyrenderer 	enabled
trac.web.auth.loginmodule 	disabled
tracduplicates.web_ui.duplicatesmodule 	disabled
tracopt.mimeview.php.phprenderer 	enabled
tracopt.ticket.commit_updater.* 	enabled
tracvote.* 	enabled
header_logo 	alt 	Domain Trac System
height 	-1
link 	http://trac.domain.net:8000/
src 	http://ali.domain/gp_logo.jpg
width 	-1
inherit 	plugins_dir 	
templates_dir 	
logging 	log_file 	/home/trac/gptrac/log/trac.log
log_format 	
log_level 	WARNING
log_type 	file
milestone 	stats_provider 	DefaultTicketGroupStatsProvider
mimeviewer 	max_preview_size 	262144
mime_map 	text/x-dylan:dylan,text/x-idl:ice,text/x-ada:ads:adb
php_path 	php
tab_width 	8
treat_as_binary 	application/octet-stream,application/pdf,application/postscript,application/rtf
notification 	admit_domains 	
always_notify_owner 	true
always_notify_reporter 	true
always_notify_updater 	false
email_sender 	SmtpEmailSender
ignore_domains 	
mime_encoding 	none
sendmail_path 	sendmail
smtp_always_bcc 	
smtp_always_cc 	
smtp_default_domain 	
smtp_enabled 	true
smtp_from 	trac@domain.net
smtp_from_name 	Domain Trac System
smtp_password 	
smtp_port 	25
smtp_replyto 	trac@domain.net
smtp_server 	localhost
smtp_subject_prefix 	__default__
smtp_user 	
ticket_subject_template 	$prefix #$ticket.id: $summary
use_public_cc 	false
use_short_addr 	false
use_tls 	false
project 	admin 	
admin_trac_url 	.
descr 	Domain Trac System
footer 	Visit the Trac open source project at<br />
icon 	common/trac.ico
name 	Domain Trac
url 	
query 	default_anonymous_query 	status!=closed&cc~=$USER
default_query 	status!=closed&owner=$USER
items_per_page 	100
ticketlink_query 	?status=!closed
report 	items_per_page 	100
items_per_page_rss 	0
revisionlog 	default_log_limit 	100
roadmap 	stats_provider 	DefaultTicketGroupStatsProvider
search 	default_disabled_filters 	
min_query_length 	3
sqlite 	extensions 	
svn 	branches 	trunk,branches/*
tags 	tags/*
ticket 	commit_ticket_update_check_perms 	true
commit_ticket_update_commands.close 	close closed closes fix fixed fixes
commit_ticket_update_commands.refs 	addresses re references refs see
commit_ticket_update_envelope 	
commit_ticket_update_notify 	true
default_cc 	
default_component 	website/misc
default_description 	
default_keywords 	
default_milestone 	unscheduld
default_owner 	
default_priority 	Prio 1
default_resolution 	fixed
default_severity 	
default_summary 	
default_type 	bug
default_version 	live/all
max_comment_size 	262144
max_description_size 	262144
preserve_newlines 	default
restrict_owner 	false
workflow 	ConfigurableTicketWorkflow,TicketWorkflowOpOwnerReporter,TicketWorkflowOpXRef
ticket-workflow 	accept 	new,assigned,accepted,reopened -> accepted
accept.operations 	set_owner_to_self
accept.permissions 	TICKET_MODIFY
dup 	* -> closed
dup.name 	close
dup.operations 	set_resolution,xref
dup.set_resolution 	duplicate
dup.xref 	Ticket %s has been marked as a duplicate of this ticket.
dup.xref_local 	Closed as duplicate of %s.
leave 	* -> *
leave.default 	1
leave.operations 	leave_status
reassign 	new,assigned,accepted,reopened -> assigned
reassign.operations 	set_owner
reassign.permissions 	TICKET_MODIFY
reopen 	closed -> reopened
reopen.operations 	del_resolution
reopen.permissions 	TICKET_CREATE
resolve 	new,assigned,accepted,reopened -> closed
resolve.operations 	set_resolution
resolve.permissions 	TICKET_MODIFY
ticketlog 	log_pattern 	.*\s*#%s+\s+.*
timeline 	abbreviated_messages 	True
changeset_collapse_events 	false
changeset_long_messages 	false
changeset_show_files 	0
default_daysback 	30
max_daysback 	90
newticket_formatter 	oneliner
ticket_show_details 	false
trac 	auth_cookie_lifetime 	0
auth_cookie_path 	
authz_file 	
authz_module_name 	
auto_preview_timeout 	2.0
auto_reload 	False
backup_dir 	db
base_url 	http://trac.domain.net:8000/
check_auth_ip 	false
database 	sqlite:db/trac.db
debug_sql 	False
default_charset 	iso-8859-15
default_handler 	WikiModule
default_timezone 	
genshi_cache_size 	128
htdocs_location 	
ignore_auth_case 	false
mainnav 	wiki,timeline,roadmap,browser,tickets,newticket,search
metanav 	login,logout,prefs,help,about
mysqldump_path 	mysqldump
never_obfuscate_mailto 	false
permission_policies 	DefaultPermissionPolicy, LegacyAttachmentPolicy
permission_store 	DefaultPermissionStore
pg_dump_path 	pg_dump
repository_dir 	
repository_sync_per_request 	(default)
repository_type 	svn
request_filters 	
resizable_textareas 	true
secure_cookies 	False
show_email_addresses 	false
show_ip_addresses 	false
timeout 	20
use_base_url_for_redirect 	False
vote 	paths 	/wiki*,/ticket*
wiki 	ignore_missing_pages 	false
max_size 	262144
render_unsafe_content 	false
split_page_names 	false

comment:8 Changed 4 years ago by richard

This plugin did not support multi repository feature of trac 0.12 by now. I will fix it soon.

comment:9 Changed 4 years ago by richard

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [8373]) Fixed #7508

  • support multi repository

Add Comment

Modify Ticket

Action
as closed The owner will remain richard.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.