Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#7555 closed defect (duplicate)

AnnouncerPlugin keeps sending mails with always_notify_* disabled completely

Reported by: anonymous Owned by: doki_pen
Priority: low Component: AnnouncerPlugin
Severity: normal Keywords: nevernotify
Cc: hasienda, crunk Trac Release: 0.12

Description

Hey!

After Installing AnnouncerPlugin Trac keeps sending me mails about tickets I changed via LegacyTicketSubscriber, although I disabled that option in my preferences. For clarification: I am user 'crunk', owner is 'dampsey' The config is as following:

[announcer]
admit_domains =
always_notify_component_owner = false
always_notify_owner = false
always_notify_reporter = false
always_notify_updater = false
default_email_format = text/html
email_address_resolvers = SpecifiedEmailResolver, SessionEmailResolver
ignore_domains =
mime_encoding = base64
smtp_always_bcc =
smtp_always_cc =
smtp_default_domain =
smtp_enabled = true
smtp_from = trac-no-reply@*****.com
smtp_from_name = Trac
smtp_password =
smtp_port = 25
smtp_replyto = no-reply@*****.com
smtp_server = smtp.*****.com
smtp_subject_prefix = __default__
smtp_timeout = 30
smtp_user =
ticket_email_header_fields = owner, reporter, milestone, component, priority, severity.
ticket_email_subject = Ticket #${ticket.id}: ${ticket['summary']}.
ticket_subject_template = $prefix $ticket.id: $summary
use_public_cc = false
use_short_addr = false
use_tls = false

In my desperation I also added th following code above the [announcer] part:

[notification]
always_notify_component_owner = false
always_notify_owner = false
always_notify_reporter = false
always_notify_updater = false

But still the log says:

2010-08-26 16:25:57,076 Trac[api] DEBUG: AnnouncementSystem found the following subscribers capable of handling 'ticket, changed': LegacyTicketSubscriber, CarbonCopySubscriber, TicketComponentSubscriber, TicketCustomFieldSubscriber, UserChangeSubscriber, WatchSubscriber
2010-08-26 16:25:57,078 Trac[ticket_compat] DEBUG: LegacyTicketSubscriber added 'dampsey (authenticated)' because of rule: always_notify_component_owner
2010-08-26 16:25:57,080 Trac[ticket_compat] DEBUG: LegacyTicketSubscriber added 'dampsey (authenticated)' because of rule: always_notify_owner
2010-08-26 16:25:57,081 Trac[ticket_compat] DEBUG: LegacyTicketSubscriber added 'crunk (authenticated)' because of rule: always_notify_reporter
2010-08-26 16:25:57,082 Trac[ticket_compat] DEBUG: LegacyTicketSubscriber added 'crunk (authenticated)' because of rule: always_notify_updater
2010-08-26 16:25:57,085 Trac[api] DEBUG: AnnouncementSystem has found the following subscriptions: [dampsey(authenticated) via email], [crunk(authenticated) via email]
2010-08-26 16:25:57,085 Trac[email_distributor] DEBUG: EmailDistributor has found the following formats capable of handling 'email' of 'ticket': text/html, text/plain
2010-08-26 16:25:57,086 Trac[email_distributor] DEBUG: EmailDistributor determined the preferred format for 'dampsey (authenticated)' is: text/html
2010-08-26 16:25:57,088 Trac[email_distributor] DEBUG: EmailDistributor found the address '*******@****.com' for 'dampsey (authenticated)' via: SessionEmailResolver
2010-08-26 16:25:57,089 Trac[email_distributor] DEBUG: EmailDistributor determined the preferred format for 'crunk (authenticated)' is: text/html
2010-08-26 16:25:57,090 Trac[email_distributor] DEBUG: EmailDistributor found the address '*******@****.com' for 'crunk (authenticated)' via: SessionEmailResolver
2010-08-26 16:25:57,090 Trac[email_distributor] DEBUG: EmailDistributor is sending event as 'text/html' to: *******@****.com, *******@****.com
2010-08-26 16:25:57,238 Trac[email_distributor] DEBUG: EmailDistributor took 0.08 seconds to send.

Why? As one can see, always_notify_updater is disabled...

I am using AnnouncerPlugin 1.0-a1

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by rjollos

  • Cc hasienda added; anonymous removed

See #7512. You'll need to install from the trunk to get never notify updater functionality.

comment:2 Changed 4 years ago by hasienda

  • Keywords nevernotify added
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed
  • Summary changed from Trac/AnnouncerPlugin keeps sending mails to AnnouncerPlugin keeps sending mails with always_notify_* disabled completely

Right, this is still WiP, that is in trunk (development for 0.12), so needs to be finally merged to 0.11 branch.

I'd appreciate your feedback, if you'd be able to test on Trac 0.12. If you still need the 0.11 version, you'll have to wait. I won't make promises, but expect it soon.

However, having to delete some more tickets doesn't justify a major severity for me, but YMMV. Get subscribed to your tickets at least via adding your email address to 'cc' field, or register with this site, if your privacy is of much concern (would enable you to just put your user name in).

Having said all this, it's a duplicate of #7512, so no need to track effort on this subject twice. Please try harder in finding your problem within existing tickets, and prefer comments to existing tickets over creating new ones without new information. So you'll enable us to do less ticket management and more coding. Thanks. :-)

comment:3 Changed 4 years ago by crunk

Thanks for your efforts. I just moved to trunk and experiencing new error. Will create a new ticket :)

comment:4 Changed 4 years ago by crunk

  • Cc crunk added

Add Comment

Modify Ticket

Action
as closed The owner will remain doki_pen.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.