Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#757 closed enhancement (worksforme)

RFE: Arbitrary Hierarchy Levels

Reported by: chtaylo3@… Owned by: Blackhex
Priority: normal Component: DiscussionPlugin
Severity: trivial Keywords:
Cc: Trac Release: 0.9

Description

Right now you only have 2 levels of discussion Hierarchy, the Forum and the Topics. It would be nice to support more, say somewhere in the neighborhood of 3-4, hierarchy levels.

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by chtaylo3@…

  • Component changed from TracHacks to DiscussionPlugin
  • Owner changed from athomas to Blackhex

OK, I'm an idiot ... I didn't set the right component.

comment:2 Changed 8 years ago by Blackhex

  • Status changed from new to assigned

You forot forum groups, so that is 3rd levels. What could be 4th?

comment:3 Changed 8 years ago by chtaylo3@…

I might be mising a configuration setting, but when I set this up, I only get the Forum List and then the Topics List (which is a series of messages). So I guess that is 3 levels, Forum, Topics, Messages.

What I'm looking for is something where I can have a breakdown like this: / /Development /Development/Component A /Development/Component B /Troubleshooting/ /Troubleshooting/Component A /Troubleshooting/Component B /Management/ /Management/Planning /Management/Risks etc

this is linked to the issue #756 (Forum based permissions) becuase we want the users to be able to access the troubleshooting area only .... and the developers to access the development and troubleshooting areas only ... you get the idea.

comment:4 Changed 8 years ago by Blackhex

There is no groups defined by default but when you go on WebAdmin page there is Forum Groups section where you can define new ones and Forums section where you can assign forums to groups. All forums in all groups are displayed together (but groupped) right now but implement seprarate group view can be done (sometime :-) ). I think that this 3 levels are sufficient for your breakdown cause you can have groups Development, Troubleshoooting and Management where would be Components forums and inside them all topics. (This is the way how it was designed actually.)

comment:5 Changed 8 years ago by coderanger

You could also just have two Tracs, one for development and another for troubleshooting.

comment:6 Changed 8 years ago by chtaylo3@…

It sounds like this forum group is what I need. Unfortunately, I'm not seeing it in WebAdmin. I thought this might be because I haven't given myself the correct privileges, but I'm down as Trac_Admin and I don't see anything like Discussion_Admin ... only Discussion_Moderate (which I have).

TIA Chris

comment:7 Changed 8 years ago by chtaylo3@…

  • Resolution set to worksforme
  • Status changed from assigned to closed

Wierd, I restarted apache and I see the Forum Groups now. I'm closing this ticket. Thanks so much!

-Chris

comment:8 Changed 8 years ago by Blackhex

This was maybe caused by wrong plugin load order. Trac 0.9 has no options to guarant correct load order. Ticket was assigned to 0.9 trac release so I'm guessing that you have 0.9. Update to 0.10 ASAP :-).

Add Comment

Modify Ticket

Action
as closed The owner will remain Blackhex.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.