Modify

Opened 4 years ago

Closed 3 years ago

#7674 closed enhancement (fixed)

Improve layout of fields when some are hidden

Reported by: robguttman Owned by: robguttman
Priority: low Component: DynamicFieldsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

Currently when there are hidden fields you see a gap in the table of fields where the hidden field was. (Same for header up top.) This is ugly. All visible fields should get collapsed so there are no gaps from the hidden fields.

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by robguttman

(In [8804]) refs #7674: now provides layout feature so that visible fields collapse and fill any hidden fields. A more subtle enhancement/fix is that some rules now cascade - e.g., if a clear rule clears a field A and then if a hide rule hides a field B if field A is empty, then field B will get hidden when field A gets cleared. In order words, the rules are cascaded/chained. (If this doesn't make sense don't worry about it. :)

comment:2 Changed 4 years ago by robguttman

  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from defect to enhancement

This new layout feature is currently automatic and non-configurable. If you strongly preferred the older ("uglier") behavior, please let me know and I can see about making the new layout optional.

Also, I bumped the minor version for this feature so we're now at 1.1.0 for the Trac 0.11 version.

comment:3 Changed 4 years ago by hasienda

(In [9688]) DynamicFieldsPlugin: Merge changeset [8804] to 0.12 branch, refs #7674.

This adds collapsing layout to ticket fields grid and support for cascading rules here. Code has been modified a bit, especially to limit line-length to < 80 chars.

comment:4 Changed 4 years ago by hasienda

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Trac Release changed from 0.11 to 0.12

I've been testing with following settings in my trac.ini:

[ticket-custom]
parents = text
parents.label = Vorgänger-Vorgang
parents.show_when_type = Fehler|Verbesserung (pref)
component.show_when_type = invalid_value (pref)
component.clear_on_hide = false
milestone.show_when_type = invalid_value (pref)

and ticket form looks nicer indeed, but I get witnessed reproducible complaints by Firebug about too much recursion, mentioning rules.js (line 119) and dynfields.js (line 78) in the JS traceback.

The same settings work in the 0.12 branch without complaints prior to changeset [9688], did even double-check by downgrading to that older version (2.1.0). Same applies for [9689]. [9690] stops not only that complains, but the whole plugin seems non-functional now with that changes applied.

I'd appreciate your code review of my changes, because probably all this is due to my own modifications. I'll try corresponding 0.11 code later.

comment:5 Changed 4 years ago by robguttman

Steffen, I observed that "too much recursion" as well and fixed it with [9667]. Note the moving of line 105 to 92 which should fix that problem.

comment:6 Changed 4 years ago by hasienda

I see.

I've tested v1.2.0 now. It's hiding milestone and component drop-down/field, so this is just about a/my fault in v2.2.0 (current 0.12 branch).

comment:7 Changed 3 years ago by robguttman

  • Resolution set to fixed
  • Status changed from reopened to closed

This is done. Any 0.12 branch issues will be handled as part of a separate effort.

Add Comment

Modify Ticket

Action
as closed The owner will remain robguttman.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.