Modify

Opened 4 years ago

Closed 4 years ago

#7702 closed defect (duplicate)

Switch from deprecated `sha` module to modern `hashlib` [patch]

Reported by: krigstask Owned by: pkropf
Priority: normal Component: GraphvizPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Running Trac with GraphvizPlugin installed results in lots of errors like

DeprecationWarning: the sha module is deprecated; use the hashlib module instead

Simple patch against HEAD fixing the issue is attached.

Attachments (1)

trac_grv.patch (790 bytes) - added by krigstask 4 years ago.
sha->hashlib

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by krigstask

sha->hashlib

comment:1 Changed 4 years ago by krigstask

  • Cc anonymous added; sterkrig@… removed
  • Resolution set to duplicate
  • Status changed from new to closed

Sorry, should search tickets first.

Duplicate of #5747

Add Comment

Modify Ticket

Action
as closed The owner will remain pkropf.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.