Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7706 closed defect (duplicate)

ticket.query does not return more than 100 elements

Reported by: sanjay Owned by: osimons
Priority: high Component: XmlRpcPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

This is really urgent so I hope you can help.

I have a trac database with around 900 tickets. All tickets are assigned to the component "test".
The following query only returns an array from 0-100 instead of 0-900.

Here is the query in python (I have also tested this via c#)
#show open tickets
q = p.ticket.query("component=test")
print "navigation tickets: (%s)" % q

I have tried this with c# and python but I always just get a max array of 100!!

Here is the output:
C:\sandbox\pythontest>python myscript.py
[1, 1, 0]
test tickets: ([1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31,

32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65,
66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86, 87, 88, 89, 90, 91, 92, 93, 94, 95, 96, 97, 98, 99,
100])

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by osimons

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #6512.

comment:2 Changed 4 years ago by anonymous

fixed. just had to change the max size for query in trac settings.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from osimons. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.