Modify

Opened 4 years ago

Closed 4 months ago

#7764 closed defect (fixed)

Using non tcf_ field as the parent of chained fields

Reported by: mehdiru <mehdi@…> Owned by: richard
Priority: normal Component: TracTicketChainedFieldsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

Hi,
Thanks for the great job!
It would be cool if there was a possibility to have standard fields (for example component) as the top-level field. This woudl help me implement a great functionality for my projects: subcomponents :)

Thanks
ie. By the way it works for me on trac 0.12

Attachments (1)

screenshot.png (28.4 KB) - added by mehdi@… 3 years ago.
Two component fileds!

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by richard

  • Resolution set to duplicate
  • Status changed from new to closed

This feature have been implemented in #6684.

comment:2 Changed 4 years ago by mehdiru <mehdi@…>

  • Resolution duplicate deleted
  • Status changed from closed to reopened

THe following configuration doesn't work:

{
    "component": {
        "Network": {
            "tcf_subcomp": {
                "OpenVPN": {},
                "Trac": {},
                "Mercurial": {}
            }
        },
        "Google Apps": {
            "tcf_subcomp": {
                "": {}
            }
        },
        "Soft infra": {
            "tcf_subcomp": {
                "ModelSim": {}
            }
        }
    }
}

Here "component" is the trac's component list which I prealably configured.

comment:3 Changed 3 years ago by anonymous

This is working for me except I have a bug where the correct values are not being selected as it's only the input type which is searched for.

comment:4 Changed 3 years ago by anonymous

See the patch in #8082 that I came up with and this will work.

comment:5 Changed 3 years ago by richard

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [9928]) Fixed #7764

Changed 3 years ago by mehdi@…

Two component fileds!

comment:6 Changed 3 years ago by Mehdi Taileb <mehdi@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect

In my case is shows two "component" fields!! cf. the attached file (http://trac-hacks.org/attachment/ticket/7764/screenshot.png)

trac.ini:

[tcf]
chained_fields = component, tcf_subcomp
[ticket-custom]
tcf_subcomp = text
tcf_subcomp.format = plain
tcf_subcomp.label = Sub-Component
tcf_subcomp.order = 0

Chained fields (admin pannel) content:

{
    "component": {
        "Network": {
            "tcf_subcomp": {
                "OpenVPN": {},
                "Trac": {},
                "Mercurial": {},
                "Firewall":{},
                "MySQL":{},
                "Joomla":{},
                "Security":{}
            }
        },
        "Google Apps": {
            "tcf_subcomp": {
                "Authentication": {}
            }
        },
        "Soft infra": {
            "tcf_subcomp": {
                "ModelSim": {}
            }
        }
    }
}

comment:7 Changed 3 years ago by richard

My environment has no such phenomenon.

[9928] did not touch code for newticket path, so I guess it is caused by something else.

Could you test it with previous version? Or try clear cache and refresh?

comment:8 Changed 4 months ago by rjollos

  • Resolution set to fixed
  • Status changed from reopened to closed

Closing since there has been no response to the feedback request in comment:7.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from richard. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.