Modify

Opened 3 years ago

Closed 3 years ago

#7879 closed defect (wontfix)

"502 Bad Gateway" when using CodeExampleMacro in ticket comments

Reported by: rjollos Owned by: nuald
Priority: normal Component: CodeExampleMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

I can use the following snipet in a wiki page and it works fine, but I see a 502 Bad Gateway error when putting it in a ticket comment.

{{{
#!CodeExample
## path = /Projects/Presto/Software/branches/T666-RO/acqserver/VdasController.cpp@4704:290-331#L290
#!cpp
}}}

I've seen this error with the ChangeLogMacro, which I maintain, but have yet to track down the source of the problem. See #6370.

I'm running Trac 0.11.7.

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by rjollos

Thank you for providing such a useful macro, btw! I've been using this for code reviews, and it is by far the most straightforward way to do code reviews in Trac.

comment:2 Changed 3 years ago by rjollos

  • Description modified (diff)

comment:3 Changed 3 years ago by nuald

  • Status changed from new to assigned

Sorry, can't reproduce. Tried with the similar example on Trac 0.11.7. Can you provide Trac logs related with this error?

Hint: set up [logging] section in the trac.ini.

comment:4 Changed 3 years ago by rjollos

Thank you for testing it out. I will talk with my hosting provider and see what they can provide in terms of logs, and whether they have any idea of what the problem might be.

comment:5 Changed 3 years ago by rjollos

I'm still waiting for my hosting provider to investigate this issue, but will make sure to follow up as soon as I have something to report.

comment:6 Changed 3 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from assigned to closed

I'm closing this seems it seems to be some issue specific to the hosting provider I was using, and I don't see the issue now that they migrated me to a different server.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from nuald. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.