Modify

Opened 4 years ago

Closed 2 years ago

#7882 closed defect (duplicate)

MissingSectionHeaderError: File contains no section headers. file: C:\passwd, line: 1 'pjyang::37af6f35659301a97fd1ef8f944f34de\n'

Reported by: PJYang2009@… Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: password file
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'5c2779003970b6454cf6a322',
 'cat_id': u'accounts',
 'panel_id': u'users',
 'path_info': None,
 'remove': u'Remove selected accounts'}

User agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

System Information

Trac 0.12
Genshi 0.6
mod_python 3.3.1
pysqlite 2.5.5
Python 2.5.4 (r254:67916, Dec 23 2008, 15:10:54) [MSC v.1310 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.6.11
Subversion 1.6.6 (r40053)
jQuery 1.4.2

Enabled Plugins

tracaccountmanager 0.3dev-r9338

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\trac\admin\web_ui.py", line 116, in process_request
    path_info)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 123, in render_admin_panel
    return self._do_users(req)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 252, in _do_users
    for username in self.account_manager.get_users():
  File "build\bdist.win32\egg\acct_mgr\api.py", line 159, in get_users
    users.extend(store.get_users())
  File "build\bdist.win32\egg\acct_mgr\svnserve.py", line 53, in get_users
    return [user for (user,password) in self._config.options('users')]
  File "build\bdist.win32\egg\acct_mgr\svnserve.py", line 46, in _config
    self._userconf.parse_if_needed()
  File "build\bdist.win32\egg\trac\config.py", line 262, in parse_if_needed
    self.parser.read(self.filename)
  File "C:\PROGRA~1\BITNAM~1\python\lib\ConfigParser.py", line 267, in read
    self._read(fp, filename)
  File "C:\PROGRA~1\BITNAM~1\python\lib\ConfigParser.py", line 462, in _read
    raise MissingSectionHeaderError(fpname, lineno, line)
MissingSectionHeaderError: File contains no section headers.
file: C:\passwd, line: 1
'pjyang::37af6f35659301a97fd1ef8f944f34de\n'

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by rjollos

  • Component changed from SELECT A HACK to AccountManagerPlugin
  • Owner set to hasienda

Yet another incorrectly filed ticket.

comment:2 Changed 2 years ago by hasienda

  • Keywords password file added
  • Resolution set to duplicate
  • Status changed from new to closed

Sorry, that this report has gone undetected for such a long time. However, only the reporter is in charge to select an appropriate plugin for getting needed attention to his/her issue.

See #7260 for a similar issue, I already commented on. Sad to say, I got no response and therefore could not really do anything about it.

Btw, the double colon seems plain wrong. Did someone try to add a username with colon in it? This is prevented since [9260], because it's known to break applications exactly in the way shown here.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.