Modify

Opened 4 years ago

Closed 2 years ago

#7936 closed defect (worksforme)

Blocking / Blocked By ticket numbers are not links.

Reported by: vladshikhov@… Owned by: coderanger
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: vladshikhov@… Trac Release: 0.12

Description

I've installed TracMasterTickets-3.0.1 (have Genshi-0.6 and Trac-0.12.1).

The Blocking/Blocked By ticket numbers in the ticket window are not links.

Attachments (1)

trac.png (1.8 KB) - added by vladshikhov@… 4 years ago.
Screenshot

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by vladshikhov@…

Screenshot

comment:1 Changed 4 years ago by vladshikhov@…

  • Type changed from defect to enhancement

One should wait some time have plugin fully working. Please, fix it or document it in readme.

comment:2 follow-up: Changed 3 years ago by anonymous

  • Type changed from enhancement to defect

I have exactly the same problem. It was working before I upgraded to 0.11.7 (from 0.11.2 I believe - I did a Debian upgrade from lenny to squeeze).

I did some digging and post_process_request is definitely returning the modified data variable with linkified IDs so I guess that it is something further up that is not displaying them as hyperlinks.

Changing to defect as it was working previously.

comment:3 in reply to: ↑ 2 Changed 3 years ago by anonymous

Replying to anonymous:

I have exactly the same problem.

(me again) Note I am using version 2.2 of the plugin.

comment:4 Changed 3 years ago by anonymous

Please try to replace in web_ui.py:

  • this
        FIELD_XPATH = 'div[@id="ticket"]/table[@class="properties"]/td[@headers="h_%s"]/text()'
    
  • with this
        FIELD_XPATH = '//div[@id="ticket"]/table[@class="properties"]//td[@headers="h_%s"]/text()'
    

Looks like the Genshi 'Transformator' has changed a bit.

comment:5 Changed 3 years ago by Mazda86

FYI - this fix worked fine for me. I'm using Trac 0.11.7 with version 2.1.3 of the plugin.

comment:6 Changed 2 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

The fix described in comment:4 has been applied to the 0.11 branch: 47a7aee54553fb718c376cfa9d7de4389a391e33 with the log message: Fix hyperlinks for dependent tickets (#7139, #4976).

Please reopen if you can reproduce with the latest revision of the plugin on either 0.11 or 0.12.

Add Comment

Modify Ticket

Action
as closed The owner will remain coderanger.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.