Modify

Opened 8 years ago

Closed 8 years ago

#812 closed defect (duplicate)

TracEnv won't upgrade

Reported by: anonymous Owned by: Blackhex
Priority: normal Component: DiscussionPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

After installing from source and modifying the trac.ini configuration to include Discussion. I have to upgrade the environment, but it doesn't work:

#!/bin/bash
devspot:~/discussionplugin/0.10# trac-admin /tracenvironment/ upgrade
Database is up to date, no upgrade necessary.

So I get errors about column names when I try Discussion :

Traceback (most recent call last):
  File "/var/lib/python-support/python2.3/trac/web/main.py", line 356, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.3/trac/web/main.py", line 224, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/tracdiscussion/core.py", line 70, in process_request
  File "build/bdist.linux-i686/egg/tracdiscussion/api.py", line 31, in render_discussion
  File "build/bdist.linux-i686/egg/tracdiscussion/api.py", line 352, in _do_action
  File "build/bdist.linux-i686/egg/tracdiscussion/api.py", line 785, in get_groups
  File "/var/lib/python-support/python2.3/trac/db/util.py", line 48, in execute
    return self.cursor.execute(sql)
  File "/usr/lib/python2.3/site-packages/sqlite/main.py", line 244, in execute
    self.rs = self.con.db.execute(SQL)
DatabaseError: no such column: g.id

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by Blackhex

  • Resolution set to duplicate
  • Status changed from new to closed

This is the duplicate of ticket #790, but thank you for reporting. Changes I made didn't help to solve this problem on some systems. Could you report info about your sqlite and pysqlite version to ticket #790. Perhaps some versions of sqlite has problem with this SQL statement:

SELECT g.id, g.name, g.description, (SELECT COUNT(f.id) AS forums FROM forum f WHERE f.forum_group = g.id) FROM forum_group g ORDER BY g.id ASC;

but I don't know yet which versions and why.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Blackhex. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.