Modify

Opened 3 years ago

Closed 3 years ago

#8347 closed defect (duplicate)

No way to limit access to Hours for anonymous users

Reported by: christer@… Owned by: rjollos
Priority: normal Component: TracHoursPlugin
Severity: normal Keywords: 0.12 hours access user anonymous
Cc: Trac Release: 0.12

Description

I was not able to find any information on how to fix the TracHoursPlugin so that it does not show up in the menu for 'anonymous' access. The page also allows for access without being logged in. There is no HOURS_VIEW (or similar) access level to grant to people in the Admin page.

How to Reproduce

Without being logged in (or being timed out from login), go directly to a specific Hour entry, e.g.:

  • https://mydomain.com/trac/hours/4

System Information

Trac 0.12
Babel 0.9.5
Docutils 0.6
Genshi 0.6
mod_wsgi 3.2 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
MySQL server: "5.0.77-log", client: "5.1.52", thread-safe: 0
MySQLdb 1.2.3c1
Pygments 1.3.1
Python 2.7 (r27:82500, Sep 16 2010, 18:02:00)
[GCC 4.5.1 20100907 (Red Hat 4.5.1-3)]
setuptools 0.6
Subversion 1.6.13 (r1002816)
jQuery 1.4.2
[trac]
permission_policies = DefaultPermissionPolicy, LegacyAttachmentPolicy
permission_store = DefaultPermissionStore

[components]
componentdependencies.componentdependency.componentdependencyplugin = enabled
ticketsidebarprovider.ticketsidebar.ticketsidebarprovider = enabled
trachours.hours.trachoursplugin = enabled
trachours.multiproject.multiprojecthours = enabled
trachours.setup.setuptrachours = enabled
trachours.web_ui.trachoursroadmapfilter = enabled
trachours.web_ui.trachourssidebarprovider = enabled
trachours.web_ui.tracuserhours = enabled
  • Other installed Plugins (in order, all performed on 2010-12-28):
    • easy_install "http://trac-hacks.org/svn/tracsqlhelperscript/0.12"
    • easy_install "http://trac-hacks.org/svn/ticketsidebarproviderplugin/0.11"
    • easy_install "http://trac-hacks.org/svn/componentdependencyplugin/0.11"
    • easy_install "http://trac-hacks.org/svn/trachoursplugin/branches/0.12"
    • easy_install "https://trac-hacks.org/svn/accountmanagerplugin/trunk"
    • easy_install "http://trac-hacks.org/svn/trachoursplugin/branches/0.12"
      • yes, had to run this a second time because the Hours functionality disappeared after installing the AccountManagerPlugin

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #4632.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.