Modify

Opened 3 years ago

Closed 3 years ago

#8390 closed defect (duplicate)

SQL error when using PostgreSQL viewing /hours where no tickets exist

Reported by: piperad Owned by: rjollos
Priority: normal Component: TracHoursPlugin
Severity: normal Keywords: postgresql postgres sql syntax error
Cc: Trac Release: 0.11

Description

While this works fine on SQLite the "WHERE ticket IN ()" is invalid for PostgreSQL. As such I have tweaked the code to merely return an empty list in this circumstance. See attached patch.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8391 (which has the patch).

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.