Modify

Opened 3 years ago

Closed 3 years ago

#8467 closed enhancement (duplicate)

Show tags not only on EDIT page

Reported by: dh1jc Owned by: athomas
Priority: normal Component: TagsPlugin
Severity: normal Keywords: wiki page
Cc: rjollos, otaku42 Trac Release: 0.11

Description (last modified by rjollos)

Hi,

I found the tags of a page at the bottom right only on the wiki_edit page.
So I changed the code wiki.py to insert the tags not before the "buttons" but behind the wikipage

  • wiki.py

     
    9797            li.append(tag.li(anchor, ' ')) 
    9898 
    9999        insert = tag.ul(class_='tags')(tag.li('Tags', class_='header'), li) 
    100         return stream | Transformer('//div[@class="buttons"]').before(insert) 
     100        return stream | Transformer('//div[contains(@class,"wikipage")]').after(insert) 
    101101 
    102102    def _update_tags(self, req, page): 
    103103        tag_system = TagSystem(self.env) 

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

  • Description modified (diff)

comment:2 Changed 3 years ago by hasienda

  • Keywords wiki page added
  • Type changed from defect to enhancement

This is an enhancement proposal/request, right?

comment:3 Changed 3 years ago by hasienda

  • Cc rjollos otaku42 added
  • Resolution set to duplicate
  • Status changed from new to closed

What revision/source have you been looking on?

This has been fixed in [7384] for trunk, so your claim is largely invalid. Would you like to express, this needs backporting?

Furthermore this is a duplicate of #3851. Discuss over there, even reopen, if you feel the need.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.