Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8483 closed defect (duplicate)

Repository Statistics don't work!

Reported by: the3illings@… Owned by: rjollos
Priority: normal Component: TracMetrixPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.12

Description

Description

I have Trac 0.12.2 with German language and the Repository Statistics chart is empty.

Reason

This is due to wrong usage of to_timestamp() function in model.py

Solution

Using to_utimestamp() instead fixes the issue!

Attachments (0)

Change History (3)

comment:1 follow-up: Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7045, I just haven't gotten around yet to applying that patch.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 4 years ago by the3illings@…

Replying to rjollos:

Duplicate of #7045, I just haven't gotten around yet to applying that patch.

I agree it's similar in content, but this issue affects model.py which is untouched in the patch of #7045. So the patch (if used as it is) won't fix this one!

Questions:

  • Are you sure to keep it closed as dublicate?
  • Or should I add my remarks in #7045?

comment:3 in reply to: ↑ 2 Changed 4 years ago by rjollos

Replying to the3illings@googlemail.com:

Questions:

  • Are you sure to keep it closed as dublicate?
  • Or should I add my remarks in #7045?

I may have left that ticket open because i wasn't sure the patch was complete. If I remember correctly, the patch in #7045 also doesn't address some timezone issues that need to be dealt with.

It seems like both this ticket and #7045 can be combined to fix the 0.12 timestamp issues. Perhaps we can work to create a new patch for #7045 that solve both issues, so I'd say let's leave #7045 open and append the info you've discovered here.

As you can probably tell, I'm not totally up to speed at the moment on the issues that need to be dealt with for this plugin, so I really appreciate your help!

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.