Modify

Opened 4 years ago

Closed 3 years ago

#8699 closed defect (fixed)

TracJsGanttPlugin doesn't show anything

Reported by: duarte.diegod@… Owned by: ChrisNelson
Priority: normal Component: TracJsGanttPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

I tried to install the TracJsGanttPlugin and follow all the instructions on the main page. However, when I try to invoke the plugin, using the following instruction:

[[TracJSGanttChart(milestone=BACEN)]]

It just renders a red box with the message: "Error: Macro TracJSGanttChart(milestone=BACEN) failed" and no more information. I commented all fields that are not being used. This are the configuration:

[trac-jsgantt]
# To work with Timing and Estimation for percent complete
fields.estimate = estimatedhours
fields.worked = totalhours
# Each unit in estimate is 1/8 of a day
days_per_estimate = 0.125
# To work with Master Tickets for dependencies
#fields.pred = blockedby
#fields.succ = blocking
# To work with Subtickets for parent/child relationships
#fields.parent = parents
# Custom fields for start and due dates
#fields.start = userstart
#fields.finish = userfinish
date_format = %Y-%m-%d
milestone_type = milestone

I also tried to uncomment fileds.start and fields.finish, but the only chance is that the red error box show "userstart" as and additional error message.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by rjollos

  • Description modified (diff)

comment:2 Changed 3 years ago by rjollos

I think this is most likely a duplicate of #8679, so please check your log messages and see if you have the same error listed there.

comment:3 Changed 3 years ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

Please reopen if you still have an issue after installing at r10255 or later.

Add Comment

Modify Ticket

Action
as closed The owner will remain ChrisNelson.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.