Modify

Opened 3 years ago

Closed 3 years ago

#8729 closed defect (duplicate)

Compilation fails on python 2.4 with Syntax Error

Reported by: ruedi.silvestri@… Owned by: ChrisNelson
Priority: normal Component: TracJsGanttPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description

On centos 5.6 with python 2.4.3 the compilation of the plugin fails with below exception:

copying build/lib/tracjsgantt/htdocs/jsgantt.js -> build/bdist.linux-i686/egg/tracjsgantt/htdocs
copying build/lib/tracjsgantt/htdocs/jsgantt.compressed.js -> build/bdist.linux-i686/egg/tracjsgantt/htdocs
byte-compiling build/bdist.linux-i686/egg/tracjsgantt/__init__.py to __init__.pyc
byte-compiling build/bdist.linux-i686/egg/tracjsgantt/tracjsgantt.py to tracjsgantt.pyc
  File "build/bdist.linux-i686/egg/tracjsgantt/tracjsgantt.py", line 139
    return (options[name] if options.get(name) else self.options[name])
                           ^
SyntaxError: invalid syntax
creating build/bdist.linux-i686/egg/EGG-INFO
copying Trac_jsGantt.egg-info/PKG-INFO -> build/bdist.linux-i686/egg/EGG-INFO

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by rjollos

This is a Python 2.5 syntax. See th:#9536 and PEP 308.

I suggest that the plugin maintainer adds install_requires = [ 'Python >= 2.5 ] to his setup.py.

Unless the plugin maintainer wishes to make his plugin 2.4 compatible, this can probably be closed as wontfix.

comment:2 Changed 3 years ago by ChrisNelson

  • Status changed from new to assigned

I plan to fix this but I don't know when I'll get to it.

comment:3 Changed 3 years ago by ChrisNelson

  • Resolution set to duplicate
  • Status changed from assigned to closed

This is a duplicate of #8484. Closing this one because that one has a patch.

comment:4 follow-up: Changed 3 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

patches of #8484 cannot be applied to the current release. Do you plan to deploy the changes to the current release?

[root@localhost tracjsgantt]# patch --dry-run tracjsgantt.py ternery.patch
patching file tracjsgantt.py
Hunk #2 succeeded at 139 (offset 7 lines).
Hunk #3 succeeded at 241 (offset 28 lines).
Hunk #4 FAIL'D at 386.
Hunk #5 FAIL'D at 487.
Hunk #6 succeeded at 338 (offset -143 lines).
Hunk #7 FAIL'D at 348.
Hunk #8 FAIL'D at 369.
Hunk #9 FAIL'D at 417.
Hunk #10 FAIL'D at 431.
6 out of 10 hunks FAIL'D -- saving rejects to file tracjsgantt.py.rej
[root@localhost tracjsgantt]# patch --dry-run tracjsgantt.py oldpython.patch
patching file tracjsgantt.py
Hunk #2 succeeded at 139 (offset 7 lines).
Hunk #3 succeeded at 241 (offset 28 lines).
Hunk #4 FAIL'D at 386.
Hunk #5 FAIL'D at 487.
Hunk #6 succeeded at 338 (offset -143 lines).
Hunk #7 FAIL'D at 348.
Hunk #8 FAIL'D at 369.
Hunk #9 FAIL'D at 417.
Hunk #10 FAIL'D at 431.
6 out of 10 hunks FAIL'D -- saving rejects to file tracjsgantt.py.rej

comment:5 in reply to: ↑ 4 Changed 3 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from reopened to closed

Replying to anonymous:

patches of #8484 cannot be applied to the current release. Do you plan to deploy the changes to the current release?

...

I didn't mean to suggest that the patch there solved the problem for users but only that it gives me a starting point on what needs to be fixed and that that ticket had more information than this one so it was the better one to keep open.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from ChrisNelson. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.