Modify

Opened 3 years ago

Closed 3 years ago

#8736 closed defect (duplicate)

AttributeError: 'TracError' object has no attribute 'acctmgr'

Reported by: angelo.rigo Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(Trying to create a new user after filling all the fields and submiting)

Request parameters:

{'__FORM_TOKEN': u'ffe546cf802a05d984a11020',
 'add': u' Add ',
 'cat_id': u'accounts',
 'email': u'joao.lennon@pucrs.br',
 'name': u'joao',
 'panel_id': u'users',
 'password': u'joaolennon',
 'password_confirm': u'joaolennon',
 'path_info': None,
 'user': u'joaolennon'}

User agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.14) Gecko/20110221 Ubuntu/10.04 (lucid) Firefox/3.6.14

System Information

Trac 0.12.1dev-r10004
Genshi 0.6
GIT 1.6.2.2
mod_python 3.3.1
pysqlite 2.4.1
Python 2.6.5 (r265:79063, Apr 9 2010, 15:16:58)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-48)]
setuptools 0.6
SilverCity 0.9.7
SQLite 3.3.6
jQuery 1.4.2

Enabled Plugins

TracAccountManager 0.2.1dev-r7737
TracGit 0.12.0.2dev-r7757

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/Trac-0.12.1dev_r10004-py2.6.egg/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/site-packages/Trac-0.12.1dev_r10004-py2.6.egg/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/site-packages/Trac-0.12.1dev_r10004-py2.6.egg/trac/admin/web_ui.py", line 116, in process_request
    path_info)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.2.1dev_r7737-py2.6.egg/acct_mgr/admin.py", line 117, in render_admin_panel
    return self._do_users(req)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.2.1dev_r7737-py2.6.egg/acct_mgr/admin.py", line 191, in _do_users
    data['acctmgr'] = e.acctmgr
AttributeError: 'TracError' object has no attribute 'acctmgr'

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by kostanos@…

The problem is in line 191 of acct_mgr/admin.py

instead dataacctmgr? = e.acctmgr
should be
dataacctmgr? = getattr(e, 'acctmgr', )

comment:2 Changed 3 years ago by kostanos@…

The problem is in line 191 of acct_mgr/admin.py

instead data['acctmgr'] = e.acctmgr

should be

data['acctmgr'] = getattr(e, 'acctmgr', '')

comment:3 Changed 3 years ago by anonymous

  • Component changed from SELECT A HACK to AccountManagerPlugin
  • Owner set to hasienda

Is this an AccountManagerPlugin issue?

comment:4 Changed 3 years ago by anonymous

Probably yes. you are right.

comment:5 Changed 3 years ago by hasienda

  • Resolution set to duplicate
  • Status changed from new to closed

#7063, #7147, #7254, #8490 and finally this one, are all more or less duplicates of #4040 as could be found only too easily by a simple query for acctmgr.

It has been fix quite a while ago. Please use a recent version (acct_mgr-0.3.2). Thanks for taking care.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.