Modify

Opened 3 years ago

Closed 2 years ago

#8879 closed defect (fixed)

TypeError: expected string or buffer

Reported by: Deniz Owned by: anbo
Priority: normal Component: ProjectPlanPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a GET operation on /ticket/3, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'3'}

User agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30

System Information

Trac 0.12
Babel 0.9.6
Genshi 0.6
pysqlite 2.6.0
Python 2.7.1 (r271:86832, Nov 27 2010, 18:30:46) [MSC v.1500 32 bit (Intel)]
pytz 2011g
setuptools 0.6c11
SQLite 3.6.21
jQuery 1.4.2

Enabled Plugins

ColorMacro Rev
lightgreentheme 0.1
projectplan 0.88.1
tracextracturl 0.3
tracmindmapmacro 0.4
tracthemeengine 2.0.1
wikicalendarmacro 2.0.0dev

Python Traceback

Traceback (most recent call last):
  File "c:\users\admini~1\appdata\local\temp\1\easy_install-pcveia\Trac-0.12-py2.7-win32.egg.tmp\trac\web\main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\users\admini~1\appdata\local\temp\1\easy_install-pcveia\Trac-0.12-py2.7-win32.egg.tmp\trac\web\main.py", line 200, in dispatch
    chosen_handler)
  File "c:\users\admini~1\appdata\local\temp\1\easy_install-pcveia\Trac-0.12-py2.7-win32.egg.tmp\trac\web\main.py", line 346, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "build\bdist.win32\egg\projectplan\ppticketviewtweak.py", line 136, in pre_process_request
    self.change_blocked_tickets( ticket_id , blocked_tickets )
  File "build\bdist.win32\egg\projectplan\ppticketviewtweak.py", line 244, in change_blocked_tickets
    saved_blocked_tickets = self.splitStringToTicketList( saved_blocked_tickets )
  File "build\bdist.win32\egg\projectplan\ppticketviewtweak.py", line 190, in splitStringToTicketList
    tickets = r.split(tickets)
TypeError: expected string or buffer

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

  • Component changed from SELECT A HACK to ProjectPlanPlugin
  • Owner set to makadev

Please make sure to assign tickets to the proper hacks.

comment:2 Changed 2 years ago by anbo

  • Owner changed from makadev to anbo

comment:3 Changed 2 years ago by anbo

  • Resolution set to fixed
  • Status changed from new to closed

[11373] (version 0.91.2) should solve the problem. However, I could not reproduce the situation where this problem should appear. Do not hesitate to reopen the ticket if the error is still occurs.

Duplicate to: #9569

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.