Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#8891 closed defect (duplicate)

no result in wiki activity

Reported by: askfor@… Owned by: dagomez
Priority: normal Component: StractisticsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

It sames that the time this plugin use is different from the time trac use.

from stractistics.util import datetime_to_secs
from trac.util.datefmt import from_utimestamp, to_utimestamp, utc

In [8]: t = datetime.now(utc)

In [9]: to_utimestamp(t)
Out[9]: 1307873775108961L

In [10]: datetime_to_secs(t)
Out[10]: 1307873775

as you can see the time stractisticsplugin got is much smaller, so this query can't got any result.

    SELECT w.author AS author, COUNT(distinct w.version) AS modifications 
    FROM wiki w
    WHERE w.time > 1300644467 AND w.time < 1307902067 
    GROUP BY author
    ORDER BY modifications DESC
    LIMIT 7  

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by olistudent

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6923.

There is also a patch attached which fixes the plugin for me.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from dagomez. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.