Modify

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#8925 closed defect (fixed)

Register form user field should be username

Reported by: ddickison Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords: register username
Cc: Trac Release: 0.12

Description

r10288 in AccountManagerPlugin (trunk) changed the server's parameter from "user" to "username", but the register.html template is still using "user". This causes an exception when trying to register.

Unless I missed something, the attached patch fixes this.

Attachments (1)

register-username.patch (835 bytes) - added by ddickison 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by ddickison

comment:1 in reply to: ↑ description Changed 3 years ago by hasienda

  • Status changed from new to assigned

Replying to ddickison:

Unless I missed something, the attached patch fixes this.

No, you're right. I missed this one. Thanks for reporting. I should really spend some time adding functional tests to prevent such regressions in the future.

comment:2 Changed 3 years ago by hasienda

I've tested the patch - and found another place, that needed a fix as well. It may not be the last one; anyway, thanks for taking care.

comment:3 Changed 3 years ago by hasienda

(In [10370]) AccountManagerPlugin: Another follow-up to changeset [10288], refs #8925.

This argument renaming obviously is a tricky thing, glad ddickison pointed
it out before the release. Thank you.

comment:4 Changed 3 years ago by hasienda

(In [10371]) AccountManagerPlugin: Repair some unit tests dedicated to htfile.py.

Mentioning (functional/unit) tests, refs #8925, I noticed that some have been
broken for a while. Good time to fix them now.

comment:5 Changed 3 years ago by hasienda

(In [10374]) AccountManagerPlugin: Correct a left-over from [10339], refs #8925 and #8939.

This has been reported by Mario Wehr, thanks. Yet I preferred to fix the
attempted variable rename according to initial intention - the other way round.

comment:6 Changed 3 years ago by hasienda

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [10393]) AccountManagerPlugin: Releasing version 0.3, pushing development to 0.4.

This new feature release finally propagates a number of solutions into an official release, after some time of testing with trunk, so explicitely closes #442, #816, #2966, #3989, #4160, #6821, #7111, #8534, #8549, #8663, #8813, #8892, #8925, #8936 and #8939.

Should have made this months ago, but felt so many pending issues were too bad for a new release. But it has been a tremendous ticket burndown since last year, so it's really worth considering an upgrade now. See fresh changelog for details.

comment:7 Changed 2 years ago by hasienda

(In [11045]) AccountManagerPlugin: Allow relative URL for HttpAuthStore configuration, refs #8925 and #9618.

Add more sophisticated logic to deal with various authentication_url values
other than full absolute URLs as suggested by Dennis McRitchie.
Minor differences to the original patch include enforced 79 char/line limit
including use of multi-line strings, modified comments and the rename of
user -> username according to previous changes, starting with [10288].

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.