Modify

Opened 3 years ago

Closed 3 years ago

#8938 closed enhancement (duplicate)

[PATCH] Replace Sha module with Hashlib

Reported by: Matt_Sable Owned by: pkropf
Priority: normal Component: GraphvizPlugin
Severity: normal Keywords:
Cc: itamarost Trac Release: 0.11

Description

In python 2.6 Sha is deprecated, and you get the warning

DeprecationWarning: the sha module is deprecated; use the hashlib module instead

This patch replaces Sha with hashlib.

Attachments (1)

patch_file.diff (777 bytes) - added by Matthew_Sable 3 years ago.
Patch

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by Matthew_Sable

Patch

comment:1 Changed 3 years ago by olaf.meeuwissen@…

Looks like a duplicate of #5747

comment:2 Changed 3 years ago by rjollos

  • Cc itamarost added
  • Resolution set to duplicate
  • Status changed from new to closed

Yeah, I agree #5747 is the better patch (unless someone has a better argument than itamarost in comment:9:ticket:5747).

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pkropf. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.