Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9009 closed defect (fixed)

Default login still used by Trac

Reported by: lastmikoi+trachacks@… Owned by: hasienda
Priority: high Component: AccountManagerPlugin
Severity: blocker Keywords: Default Auth standalone
Cc: Trac Release: 0.11

Description

I had recently installed AccountManagerPlugin 0.3.1 (tagged as stable on the main page) with Trac 0.11.7 on Debian 6, with standalone use on port 8000.

But, when I try to log-in, the usual HTTP Auth appears and so I'm not able to connect using the custom .htpasswd (different from the default, used by HTTP Auth).

Here is the component part of my trac.ini file.

[components]
acct_mgr.admin.accountmanageradminpages = enabled
acct_mgr.api.accountmanager = enabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.notification.accountchangelistener = enabled
acct_mgr.notification.accountchangenotificationadminpage = enabled
acct_mgr.web_ui.emailverificationmodule = enabled
acct_mgr.web_ui.loginmodule = enabled
acct_mgr.web_ui.registrationmodule = disabled
trac.web.auth.loginmodule = disabled

Attachments (0)

Change History (5)

comment:1 in reply to: ↑ description Changed 3 years ago by hasienda

Replying to lastmikoi+trachacks@gmail.com:

I had recently installed AccountManagerPlugin 0.3.1 (tagged as stable on the main page) with Trac 0.11.7 on Debian 6, with standalone use on port 8000.

Nice, thanks for testing this in advance.

But, when I try to log-in, the usual HTTP Auth appears and so I'm not able to connect using the custom .htpasswd (different from the default, used by HTTP Auth).
Here is the component part of my trac.ini file.

[components]
...
trac.web.auth.loginmodule = disabled

The last line should really do the trick. You're running standalone, so just tracd at port 8000, right? Please confirm, that you see the Trac login web page (almost impossible, if you disabled it - anyway), not something else.

However I still don't see, why you shouldn’t encounter the AcctMgr login. Just as a reminder, that page is looking quite similar to the Trac login web page - by intention and user request. To see anything as fancy as the preview linked in the LoginModule description, you'll need to install custom style too.

comment:2 Changed 3 years ago by hasienda

It might help to proceed, if you show me/us your tracd start-up incantation including full arguments.

And do you see anything special from a DEBUG logging output to your preferred log facility?

comment:3 Changed 3 years ago by lastmikoi+trachacks@…

Thanks for your advices.

tracd -p 8000 --basic-auth="*",/var/trac/.htpasswd,SarthTrac /var/trac/

Indeed, my tracd command is a bit custom and could made some glitches with AccountManagerPlugin, with basic-auth option activated.

I'll try without this option.

comment:4 follow-up: Changed 3 years ago by lastmikoi+trachacks@…

  • Resolution set to fixed
  • Status changed from new to closed

It works perfectly from now.

The problem was caused by basic-auth option in tracd command.

Thanks you again.

comment:5 in reply to: ↑ 4 Changed 3 years ago by hasienda

Replying to lastmikoi+trachacks@gmail.com:

Thanks you again.

You're welcome. Glad I've been able to help. And thank you for reporting back.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.