Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9081 closed defect (fixed)

Autodisable plugin for users wich have TRAC_ADMIN or TICKET_ADMIN permissions

Reported by: slevin@… Owned by: jun66j5
Priority: normal Component: TracWysiwygPlugin
Severity: normal Keywords: TRAC_ADMIN TICKET_ADMIN
Cc: Trac Release: 0.12

Description

Problem previously described in http://trac.edgewall.org/ticket/10309. Also I'm check the other *_ADMIN permissions - allway is ok. Situation can replay only when user have TRAC_ADMIN or/and TICKET_ADMIN permissions.

Attachments (2)

make_ticket_wo_trac_admin.jpeg (40.8 KB) - added by slevin@… 3 years ago.
Create ticket screen when user han't TRAC_ADMIN or TICKET_ADMIN permissions
make_ticket_with_trac_admin1.jpeg (54.0 KB) - added by slevin@… 3 years ago.
User have TRAC_ADMIN permission and can't use several control elements.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by slevin@…

Create ticket screen when user han't TRAC_ADMIN or TICKET_ADMIN permissions

Changed 3 years ago by slevin@…

User have TRAC_ADMIN permission and can't use several control elements.

comment:1 Changed 3 years ago by jun66j5

I cannot reproduce the issue with/without TICKET_ADMIN on my Trac environment that TracWysiwygPlugin and DateFieldPlugin are enabled.

If you use TicketDeletePlugin, could you disable the plugin and enable tracopt.ticket.deleter.* instead?

When you don't fix it, please check Javascirpt console.

comment:2 follow-up: Changed 3 years ago by slevin@…

  • Resolution set to fixed
  • Status changed from new to closed

Thank you!!! After I'm followed yours recommendations - allways work fine! Problem solved.

PS: But I'm can't understand why other plugin disabled that plugin.

comment:3 in reply to: ↑ 2 Changed 3 years ago by jun66j5

Replying to slevin@adriver.ru:

PS: But I'm can't understand why other plugin disabled that plugin.

TicketDeletePlugin has javascript-releated issue. The issue has been reported on ticket:6442.

The error stops the execution of all javascript codes...

Add Comment

Modify Ticket

Action
as closed The owner will remain jun66j5.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.