Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9096 closed defect (worksforme)

Create ticket using XML-RPC, returns "unsupported operand type(s) for +=: 'NoneType' and 'unicode'' while executing 'ticket.create()"

Reported by: stephon@… Owned by: osimons
Priority: normal Component: XmlRpcPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

Hello all,

I use the XMLRPC plugin to create a ticket with the XML code below

<?xml version="1.0"?>
<methodCall>
<methodName>ticket.create</methodName>
<params>
<param><string>test summary</string></param>
<param><string>test desc</string></param>
</params>
</methodCall>

it returns false but the ticket created.

<?xml version='1.0'?>
<methodResponse>
<fault>
<value><struct>
<member>
<name>faultCode</name>
<value><int>1</int></value>
</member>
<member>
<name>faultString</name>
<value><string>'unsupported operand type(s) for +=: 'NoneType' and 'unicode'' while executing 'ticket.create()'</string></value>
</member>
</struct></value>
</fault>
</methodResponse>

In the attachment is the trackback log
Would anyone please to check what the problem is?
My trac version is 0.12.2
And the XMLRPC plugin version is 1.1.2

Thanks all a lot

Attachments (1)

trac.log (12.1 KB) - added by stephon@… 3 years ago.
trackback

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by stephon@…

trackback

comment:1 Changed 3 years ago by osimons

  • Resolution set to worksforme
  • Status changed from new to closed

I've added a test case with your input, and in the functional (plain) Trac environment it works as expected.

I'm guessing this is related to some ticket-manipulating plugins you may have installed, or some other plugins or changes you've made.

comment:2 Changed 3 years ago by osimons

Oh, test added in [10614] for reference.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from osimons. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.