Modify

Opened 3 years ago

Closed 3 years ago

#9162 closed enhancement (wontfix)

HtPasswdStore should handle group file too

Reported by: anonymous Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: auth htpasswd
Cc: mortee@… Trac Release: 0.12

Description

It seems to be a valid scenario that access to a project is restricted to a specific group in the web server, and user management is done via the Trac plugin. In this case the admin can create users on the web interface, but since it's not possible to assign the right group to the new user, she can't access Trac until the group file is edited by some other means.

I guess it'd be enough to let the admin specify the group file, and a single group which is automativally assigned to any new user created using the plugin.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by anonymous

  • Cc mortee@… added

comment:2 Changed 3 years ago by hasienda

  • Keywords needinfo added
  • Type changed from defect to enhancement

Maybe.

Valid use case or not, there is no claim to actually manage htgroup files now, at least not one that I'm aware of (so this is not a bug, right?). And I'm reluctant to implement functionality that is already available from another Trac plugin. Did you have a look at HtGroupEditorPlugin and UserManagerPlugin? Adoption and integration might be an option. But for this have been too few requests by now, and I can hardly do it all on my own.

Stir up some more interest (better discuss on the th-user mailing list) and - even more important - provide patched for adding such a feature, or this will most probably collect a lot of dust while waiting here for a solution. Code rules, patches generally welcomed.

Depending on and your feedback and future plans for this plugin I'll consider keeping or closing this request (as wontfix due to presence of viable alternatives).

comment:3 follow-up: Changed 3 years ago by anonymous

Fair enough. I was under the impression that I have to look for a solution for the group issue somewhere related to the HtPasswdStore module, so I searched for it that way, and I didn't come across HtGroupEditorPlugin. Now I checked it out, and it does the trick just well, so my request is not really justified anymore. Thanks for the info.

comment:4 in reply to: ↑ 3 Changed 3 years ago by hasienda

  • Keywords needinfo removed
  • Resolution set to wontfix
  • Status changed from new to closed

Replying to anonymous:

![...] Now I checked it out, and it does the trick just well, so my request is not really justified anymore. Thanks for the info.

Good luck. Nevertheless HtGroupEditorPlugin does need some love too, but I'm too busy to do it right now. Stay tuned for later improvements, if you put this in production now. Thank you.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.