Modify

Opened 3 years ago

Closed 3 years ago

#9164 closed defect (fixed)

Error on Windows

Reported by: pdoup Owned by: jun66j5
Priority: normal Component: ExcelDownloadPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

An error is thrown by Trac when using this plugin on Windows. The following error is thrown in these cases:

WindowsError: [Error 32] The process cannot access the file because it is being used by another process: 'c:\\windows\\temp\\tmp4ftjyw'

These errors are ultimately caused by the os.unlink() calls that delete the temporary files. Apparently the files are still in use by the web server or something and Windows won't let them be deleted.

I commented out the unlink lines in the code and was able to get the excel file downloaded. After I downloaded the files, the temporary files could be deleted, so my assumption is that they cannot be deleted until the download is complete.

I also assume you wrote this on *nix so if you need any help testing on windows, please let me know.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by jun66j5

  • Status changed from new to assigned

Thanks for your reporting!

Sorry, I haven't tested on Windows.
The issue is fixed in r10647 and I tested the latest on Windows.

comment:2 Changed 3 years ago by jun66j5

  • Resolution set to fixed
  • Status changed from assigned to closed

I have confirmed the plugin works on Windows.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from jun66j5. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.