Modify

Opened 3 years ago

Closed 3 years ago

#9178 closed defect (worksforme)

Can not login or register

Reported by: NeedHelp Owned by: hasienda
Priority: low Component: AccountManagerPlugin
Severity: normal Keywords: Login Error
Cc: Trac Release: 0.12

Description

Hi all,

I've just installed trac 0.12 and accountmanager plugin, but i got an error if i click the login or register button, i don't know why, could you please help me?
Thank you.


Oops…
Trac detected an internal error:
TemplateNotFound: Template "login.html" not found
There was an internal error in Trac. It is recommended that you notify your local Trac administrator with the information needed to reproduce the issue.

To that end, you could ==== How to Reproduce ====

While doing a GET operation on /login, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'node': <tracflexwiki.core.TracFlexWikiNode instance at 0x979158c>}

User agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; InfoPath.3; .NET4.0C; .NET4.0E)

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12-py2.6.egg/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12-py2.6.egg/trac/web/main.py", line 256, in dispatch
    content_type)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12-py2.6.egg/trac/web/chrome.py", line 808, in render_template
    template = self.load_template(filename, method=method)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12-py2.6.egg/trac/web/chrome.py", line 779, in load_template
    return self.templates.load(filename, cls=cls)
  File "/usr/lib/pymodules/python2.6/genshi/template/loader.py", line 246, in load
    raise TemplateNotFound(filename, search_path)
TemplateNotFound: Template "login.html" not found
}}}  a ticket.

The action that triggered the error was:

GET: /loginTracGuide — The Trac User and Administration Guide

 

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by hasienda

Wired. 'Login' and 'Register' shouldn't produce the same error, since they use different templates.

I see the Trac version from Python traceback, but no exact AccountManager revision. Please provide that, corresponding configuration (without email or similar private details), and information about all plugins installed/enabled too. Did you check file signatures, that are provided in recent releases? Are there any complaints on Trac environment startup, if you look at the log with DEBUG logging enabled?

I see traces of FlexibleWikiPlugin activity. This is plugin badly needs some attention. Please try with this plugin disabled, and maybe without other plugins too, to rule out any interference between plugins.

General guidance: There is a 'th-users' mailing list, to keep local installation and configuration issues away from this development tracking system.

comment:2 Changed 3 years ago by hasienda

  • Priority changed from normal to low

I tear this issue down priority-wise, as the reporter seems rather unresponsive and incapable to answer even the easiest request, that for the exact plugin version used.

Best advice has already been given in the Trac error page cited above: "... notify your local Trac administrator ...", and if you happen to be the one on your own, follow my suggestions given two months(!) ago before following-up on the topic. Any news?

comment:3 Changed 3 years ago by hasienda

  • Resolution set to worksforme
  • Status changed from new to closed

Nobody could do anything about this issue without more information as requested the day after opening this ticket.

The reporter doesn't seem to care about checking comments here and reply for over 5 months now, effectively invalidating his/her claim completely by now. Such communication style is very disappointing at minimum.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.