Modify

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#9182 closed defect (invalid)

wysiwyg option for editing has disappeared after installing other plugins.

Reported by: jamil@… Owned by: jun66j5
Priority: normal Component: TracWysiwygPlugin
Severity: major Keywords: other plugins
Cc: Trac Release: 0.12

Description

I installed the wysiwyg plugin for Trac 0.12.1 on OpenBSD 4.9 (being served up with tracd) about a week ago and everything was working fine until I installed some other plugins revolving around tickets and producing gantt charts yesterday:

  • TracMasterTickets-3.0.2-py2.6.egg
  • Trac_jsGantt-0.9_r10583-py2.6.egg
  • TracSubTicketsPlugin-0.1.0-py2.6.egg
  • timingandestimationplugin-1.1.9-py2.6.egg

and now the option for editing the wiki with wysiwyg has disappeared. I have disabled and re-enabled the wysiwyg plugin through the web admin panel for plugins -- no change. I've disabled Trac_jsGantt-0.9_r10583-py2.6 (again through the web admin panel) and restarted tracd (thought that the javascript might be causing issues across plugins..) -- no change. I've checked out the latest version of wysiwyg from the svn repo:

# svn info
Path: .
URL: http://trac-hacks.org/svn/tracwysiwygplugin/0.12
Repository Root: http://trac-hacks.org/svn
Repository UUID: 7322e99d-02ea-0310-aa39-e9a107903beb
Revision: 10655
Node Kind: directory
Schedule: normal
Last Changed Author: jun66j5
Last Changed Rev: 9676
Last Changed Date: 2010-12-15 02:53:49 -0500 (Wed, 15 Dec 2010)

removed the original wysiwyg egg and installed wysiwyg again with:

# python setup.py install

while in the repo checkout but still no dice...

Everything else seems to be working normally. It's just the option for the wysiwyg editing has disappeared after installation of the other plugins mentioned above. Any suggestions or help on the matter would be most appreciated.

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by jamil@…

Progress:

I've gone into trac.ini for the project and commented out all plugins besides wysiwyg and restarted tracd -- the wysiwyg editing option for the plugin comes back!

Here's the original trac.ini components section:

[components]
mastertickets.api.masterticketssystem = enabled
mastertickets.web_ui.masterticketsmodule = enabled
talm_importer.importer.importmodule = enabled
timingandestimationplugin.api.timetrackingsetupparticipant = enabled
timingandestimationplugin.hours_layout_changer.hourslayoutchanger = enabled
timingandestimationplugin.hours_layout_changer.ticketpropslayoutchanger = enabled
timingandestimationplugin.query_webui.querywebuiaddon = enabled
timingandestimationplugin.stopwatch.ticketstopwatch = enabled
timingandestimationplugin.tande_filters.reportsfilter = enabled
timingandestimationplugin.tande_filters.timeclickfilter = enabled
timingandestimationplugin.tande_filters.totalhoursfilter = enabled
timingandestimationplugin.ticket_daemon.timetrackingticketobserver = enabled
timingandestimationplugin.ticket_daemon.timetrackingticketvalidator = enabled
timingandestimationplugin.ticket_webui.ticketwebuiaddon = enabled
timingandestimationplugin.webui.timingestimationandbillingpage = enabled
tracjsgantt.tracjsgantt.tracjsganttchart = enabled
tracjsgantt.tracjsgantt.tracjsganttsupport = enabled
tracsubtickets.api.subticketssystem = enabled
tracsubtickets.web_ui.subticketsmodule = enabled
tracwysiwyg.wysiwygmodule = enabled

and the same section but with all other components commented out:

[components]
#mastertickets.api.masterticketssystem = enabled                                                                                                                                                                                
#mastertickets.web_ui.masterticketsmodule = enabled                                                                                                                                                                             
#talm_importer.importer.importmodule = enabled                                                                                                                                                                                  
#timingandestimationplugin.api.timetrackingsetupparticipant = enabled                                                                                                                                                           
#timingandestimationplugin.hours_layout_changer.hourslayoutchanger = enabled                                                                                                                                                    
#timingandestimationplugin.hours_layout_changer.ticketpropslayoutchanger = enabled                                                                                                                                              
#timingandestimationplugin.query_webui.querywebuiaddon = enabled                                                                                                                                                                
#timingandestimationplugin.stopwatch.ticketstopwatch = enabled                                                                                                                                                                  
#timingandestimationplugin.tande_filters.reportsfilter = enabled                                                                                                                                                                
#timingandestimationplugin.tande_filters.timeclickfilter = enabled                                                                                                                                                              
#timingandestimationplugin.tande_filters.totalhoursfilter = enabled                                                                                                                                                             
#timingandestimationplugin.ticket_daemon.timetrackingticketobserver = enabled                                                                                                                                                   
#timingandestimationplugin.ticket_daemon.timetrackingticketvalidator = enabled                                                                                                                                                  
#timingandestimationplugin.ticket_webui.ticketwebuiaddon = enabled                                                                                                                                                              
#timingandestimationplugin.webui.timingestimationandbillingpage = enabled                                                                                                                                                       
#tracjsgantt.tracjsgantt.tracjsganttchart = enabled                                                                                                                                                                             
#tracjsgantt.tracjsgantt.tracjsganttsupport = enabled                                                                                                                                                                           
#tracsubtickets.api.subticketssystem = enabled                                                                                                                                                                                  
#tracsubtickets.web_ui.subticketsmodule = enabled                                                                                                                                                                               
tracwysiwyg.wysiwygmodule = enabled

So it looks like we have some sort of bad interaction between one of the other plugins and wysiwyg.

comment:2 Changed 3 years ago by jamil@…

I started uncommenting the lines in the [components] section one by one to see if the wysiwyg option would disappear but now their all uncommented and it's still present. :) Not sure what's going on but it seems the problem has gone away...

comment:3 Changed 3 years ago by anonymous

Killed and restarted tracd with:

# pkill python2.6
# tracd --port 8000 -d --basic-auth="tablomedia,/var/www/htdocs/tablomedia/conf/.htpasswd,tablomedia" /var/www/htdocs/tablomedia 

and the wysiwyg option disappeared again! I guess I'll downgrade the priority and severity since it's not a show stopper but it'd sure be nice to get a handle on this one or plugin maintenance will be difficult long term.

comment:4 Changed 3 years ago by jamil@…

  • Priority changed from high to normal
  • Severity changed from critical to major

downgrading priority and severity since I have a workaround.

comment:5 Changed 3 years ago by jun66j5

I think that the issue is the same as #8274. Please see comment:4:ticket:8274, comment:10:ticket:8274.

comment:6 follow-up: Changed 2 years ago by Matthew.Wild@…

This issue also arises with TracSubTicketsPlugin 0.1.0.

Enabled, I get no wysiwyg/textarea options. Disabled, things work fine.

comment:7 in reply to: ↑ 6 Changed 2 years ago by anonymous

Replying to Matthew.Wild@stfc.ac.uk:

This issue also arises with TracSubTicketsPlugin 0.1.0.

Enabled, I get no wysiwyg/textarea options. Disabled, things work fine.

OK, updated to TracSubTicketsPlugin 0.2.0.dev-20121012 and it works fine now.

comment:8 Changed 2 years ago by jun66j5

  • Resolution set to invalid
  • Status changed from new to closed

I tried with all versions of tracsubtickets, however, cannot reproduce. Anyway, I think the issue is the other plugin's one and I cannot fix it.

comment:9 Changed 2 years ago by rjollos

SubticketsPlugin doesn't have any Javascript, so I don't think we have to worry about errors generated in the browser. So if there is a problem caused by SubticketsPlugin, then surely there would be some information about the problem in t:TracLogging, right?

Add Comment

Modify Ticket

Action
as closed The owner will remain jun66j5.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.