Modify

Opened 3 years ago

Closed 3 years ago

#9184 closed enhancement (fixed)

Multiple parents for tickets

Reported by: anonymous Owned by: walnut
Priority: normal Component: ChildTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I have a situation where a task needs to be tracked against multiple parents.

For example,

Parent 1 - Move House Parent 2 - Purchase new house Child - Send Money to vendor (linked to parent 2 and 1)

You could specify the multiple entry by comma separated items, e.g. #1,#2?

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

Hi

If you are looking to maintain a more complex hierarchy of tickets, you'd probably be better looking at MasterTicketsPlugin. For 'non-simple' parent/child relationships, I think MasterTicketsPlugin does a really good job and has the graphical tree to give a really good overview of the hierarchy.

I've avoided anything other than a simple parent(single)-to-child(multiple) relationship in this plugin in order to keep its function clearer (and simpler!), there are certain checks performed against the parent (ticket status, type, etc...) that would be difficult if performed against multiple parents.

Maybe you should re-think the structure of your tickets? In the example you gave above (I realize it's just an example!), I would express it as a single tree, like so:

Ticket 1 - Move House

Ticket 2 - Purchase New House (child of ticket 1)

Ticket 3 - Send Money to vendor (child of ticket 2)

ie. In order to move house, you need to first buy the new house and in order to achieve this, you need to send the money to the vendor.

At the end of the day, it's easy to get carried away with the ticket hierarchy and structure (ie. you can go into minute detail and have a very deep hierarchy!) and a balance needs to be found.

For the moment, I would rather keep this plugin as intended (parent-child).

Thanks for the feedback/input.

Cheers

Mark

Add Comment

Modify Ticket

Action
as closed The owner will remain walnut.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.