Modify

Opened 3 years ago

Closed 3 years ago

Last modified 4 months ago

#9193 closed defect (cantfix)

Problem with plugin

Reported by: taliani@… Owned by: kisg
Priority: high Component: SvnAuthzAdminPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description (last modified by jun66j5)

After installing the SvnAuthzAdminPlugin I get the following output when clicking on the SubVersion link:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 436, in send_error
    data, 'text/html')
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 844, in render_template
    stream.render(method, doctype=doctype, out=buffer)
  File "/usr/lib/python2.4/site-packages/genshi/core.py", line 183, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "/usr/lib/python2.4/site-packages/genshi/output.py", line 58, in encode
    for chunk in iterator:
  File "/usr/lib/python2.4/site-packages/genshi/output.py", line 339, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.4/site-packages/genshi/output.py", line 826, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.4/site-packages/genshi/output.py", line 670, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.4/site-packages/genshi/output.py", line 771, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "/usr/lib/python2.4/site-packages/genshi/output.py", line 586, in __call__
    for ev in stream:
  File "/usr/lib/python2.4/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/lib/python2.4/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 945, in _strip_accesskeys
    for kind, data, pos in stream:
  File "/usr/lib/python2.4/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 934, in _generate
    for kind, data, pos in stream:
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/usr/lib/python2.4/site-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/lib/python2.4/site-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/lib/python2.4/site-packages/genshi/template/markup.py", line 327, in _match
    for event in stream:
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/usr/lib/python2.4/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/lib/python2.4/site-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/usr/lib/python2.4/site-packages/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/usr/lib/python2.4/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/lib/python2.4/site-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/usr/lib/python2.4/site-packages/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 554, in _flatten
    values = [event[1]
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 565, in _flatten
    result = _eval_expr(data, ctxt, vars)
  File "/usr/lib/python2.4/site-packages/genshi/template/base.py", line 277, in _eval_expr
    retval = expr.evaluate(ctxt)
  File "/usr/lib/python2.4/site-packages/genshi/template/eval.py", line 178, in evaluate
    return eval(self.code, _globals, {'__data__': data})
  File "/usr/lib/python2.4/site-packages/trac/templates/error.html", line 101, in <Expression u'project.admin_href.newticket()'>
    <form class="newticket" method="get" action="${project.admin_href.newticket()}#">
  File "/usr/lib/python2.4/site-packages/genshi/template/eval.py", line 277, in _die
    raise UndefinedError(self._name, self._owner)
UndefinedError: None has no member named "newticket"

I am new to this so any help would be appreciated.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 4 months ago by jaredbownds

Hi there,

What is the typical resolution for this particular error?

UndefinedError: None has no member named "newticket"

comment:3 Changed 4 months ago by jun66j5

  • Description modified (diff)
  • Resolution changed from fixed to cantfix

That issue is an issue in Trac core. I've filed in trac:#11733.

Also, please enable TracLogging to confirm root cause of that issue. The cause should be logged in your trac.log.

comment:4 Changed 4 months ago by rjollos

I should also mention that SvnAuthzAdminPlugin has a number of issues and isn't really suitable for use in production at this time.

Add Comment

Modify Ticket

Action
as closed The owner will remain kisg.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.