Modify

Opened 3 years ago

Closed 3 months ago

#9251 closed enhancement (duplicate)

[PATCH] del_field operation

Reported by: hju Owned by: retracile
Priority: normal Component: AdvancedTicketWorkflowPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I've implemented a new operation in our trac to clear one ore more ticket fields in a operation.

We use this operation to clear custom fields, but you may clear any field of the ticket. It is a more flexible implementation of del_resolution or del_owner

The fields are specified by their 'name' (not 'label']

    <someaction>.operations = del_field
    <someaction>.del_field = field1,field2

You just need to extend controller.py whith this snipped.

Attachments (2)

controller_del_field.patch (2.1 KB) - added by hju 3 years ago.
Code snipped operation 'del_field'
controller_del_field.py (2.1 KB) - added by hju 3 years ago.
Code snipped 'del_field'

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by hju

Code snipped operation 'del_field'

Changed 3 years ago by hju

Code snipped 'del_field'

comment:1 Changed 3 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

This is one of many tickets requesting the ability to add, delete, append to or remove from a field. I'd like to implement that feature in this plugin and then integrate it to the Trac core (​​trac:#11452). I'm closing these tickets as duplicates so that we can have the discussion in a single ticket. Duplicate of #9502.

Add Comment

Modify Ticket

Action
as closed The owner will remain retracile.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.