Modify

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#9284 closed defect (fixed)

Trac jsGantt plugin doesnt work in IE

Reported by: anonymous Owned by: ChrisNelson
Priority: highest Component: TracJsGanttPlugin
Severity: critical Keywords:
Cc: rjollos Trac Release: 0.12

Description

Hi i have installed Trac jsGantt plugin. I am using .12 trac on RHL5. I can see the chart in firefox and chrome but i cant see the chart in IE 8. Please help. I am very new to Trac. Am i missing sommething?

Attachments (0)

Change History (18)

comment:1 Changed 3 years ago by anonymous

  • Trac Release changed from 0.11 to 0.12

comment:2 follow-up: Changed 3 years ago by ChrisNelson

I use Trac 0.11 on Ubuntu and I don't have access to 0.12. IE 9 on W7 works for me, though.

If you view page source, is there JavaScript to create and populate the chart?

Is there anything in the log file?

comment:3 in reply to: ↑ 2 Changed 3 years ago by anonymous

Replying to ChrisNelson:

I use Trac 0.11 on Ubuntu and I don't have access to 0.12. IE 9 on W7 works for me, though.

If you view page source, is there JavaScript to create and populate the chart?

Is there anything in the log file?

Yes i do see JS for create and populate chart.but nothing shoows up.

src="/trac/final/chrome/tracjsgantt/jsgantt.js"></script>

<!--[if lt IE 7]>
<script type="text/javascript" src="/trac/final/chrome/common/js/ie_pre7_hacks.js"></script>
<![endif]-->
<link rel="alternate" type="application/x-wiki" title="Edit this page" href="/trac/final/wiki/WikiStart?action=edit" /><script type="text/javascript">

jQuery(document).ready(function($) {

$("#content").find("h1,h2,h3,h4,h5,h6").addAnchor(_("Link to this section"));
$("#content").find(".wikianchor").each(function() {

$(this).addAnchor(babel.format(_("Link to #%(id)s"), {id: $(this).attr('id')}));

});
$(".foldable").enableFolding(true, true);

});

</script>
<link rel="stylesheet" type="text/css" href="/trac/final/chrome/site/style.css" />

</head>
<body>

<script language="javascript">
var g = new JSGantt.GanttChart("g",document.getElementById("GanttChartDIV"), "day", "1");
var t;
window.addEventListener("resize", function () { g.Draw();

}, false);g.setShowRes(1);

g.setShowDur(1);
g.setShowComp(1);
g.setCaptionType("Resource");
g.setShowStartDate(1);
g.setShowEndDate(1);
g.setDateInputFormat("yyyy-mm-dd");
g.setDateDisplayFormat("mm/dd/yyyy");
g.setFormatArr("[u'day', u'week', u'month', u'quarter']");
g.setPopupFeatures("location=1,scrollbars=1");
t = new JSGantt.TaskItem(1,"#1:This is test ticket (closed Service Request)","2011-10-18 04:00","2011-10-18 08:00","class=ticket-class3 ticket-closed","/trac/final/ticket/1",0,"somebody",100,0,0,1,"","Please create new ticket (closed Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(4,"#4:test new1 (closed Service Request)","2011-10-07 03:00","2011-10-18 08:00","class=ticket-class3 ticket-closed","/trac/final/ticket/4",0,"None",100,0,0,1,"","test new1 ;;f;vs;vaafafas (closed Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(7,"#7:dfewef (assigned Service Request)","2011-10-03 05:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/7",0,"None",18,0,0,1,"","dfewefwfe (assigned Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(8,"#8:qwdqdqwdq (assigned Service Request)","2011-09-23 02:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/8",0,"smambakaam",63,0,0,1,"","qwdqdqdqd (assigned Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(10,"#10:dwqedqewdqd (closed Service Request)","2011-10-14 06:00","2011-10-18 08:00","class=ticket-class3 ticket-closed","/trac/final/ticket/10",0,"None",100,0,0,1,"","dwqwdqdqdqdqwdq (closed Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(13,"#13:test new ticket1 (new Service Request)","2011-10-13 02:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/13",0,"somebody",0,0,0,1,"","test new ticket1 (new Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(14,"#14:test new ticket2 (closed Service Request)","2011-10-14 00:00","2011-10-18 08:00","class=ticket-class3 ticket-closed","/trac/final/ticket/14",0,"None",100,0,0,1,"","test new ticket2 (closed Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(15,"#15:qdqwdq (new Service Request)","2011-09-20 01:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/15",0,"somebody",9,0,0,1,"","dqdqdqdw (new Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(19,"#19:saAS (assigned Service Request)","2010-12-31 02:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/19",0,"smambakaam",9,0,0,1,"","asSs (assigned Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(20,"#20:dqdqwjtyjy (assigned Service Request)","2010-09-07 01:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/20",0,"None",100,0,0,1,"","rrthegr ffgwreg njrh (assigned Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(21,"#21:dewd fwefwf wewef (assigned Service Request)","2004-07-02 07:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/21",0,"smambakaam",5,0,0,1,"","qdqdqdqd (assigned Service Request)");
g.AddTaskItem(t);
t = new JSGantt.TaskItem(22,"#22:Test Ticker (new Service Request)","2011-10-14 00:00","2011-10-18 08:00","class=ticket-class3","/trac/final/ticket/22",0,"None

comment:4 follow-up: Changed 3 years ago by ChrisNelson

I believe other people have used the plugin in Trac 0.12 and, in any event, it seems to be working and emitting the correct JS to display the chart. Is there, perhaps, a setting in your browser that keeps the JS from executing? Does the sample at http://www.jsgantt.com/ display?

comment:5 follow-up: Changed 3 years ago by falkb

I can confirm the bug on IE 8 that still has the installation default settings.

The build-in Javascript debugger of IE tells me this error at line 88 (window.addEventListener("resize", function () { g.Draw(); }, false):

Script438: The object does not support the property or method "addEventListener"

comment:6 in reply to: ↑ 5 Changed 3 years ago by falkb

Replying to falkb:

I can confirm the bug on IE 8 that still has the installation default settings.

Sorry for the typo, I have IE 9

comment:7 follow-up: Changed 3 years ago by falkb

Could be fixed using this hint: http://www.golfhos.com/topic-12192.html

comment:8 in reply to: ↑ 4 Changed 3 years ago by anonymous

Replying to ChrisNelson:

I believe other people have used the plugin in Trac 0.12 and, in any event, it seems to be working and emitting the correct JS to display the chart. Is there, perhaps, a setting in your browser that keeps the JS from executing? Does the sample at http://www.jsgantt.com/ display?

no even the default one doesnt display in IE.

comment:9 in reply to: ↑ 7 ; follow-up: Changed 3 years ago by anonymous

Replying to falkb:

Could be fixed using this hint: http://www.golfhos.com/topic-12192.html

So this needs to be fixed in plug-in code right? sorry vary new at this :(

comment:10 in reply to: ↑ 9 ; follow-up: Changed 3 years ago by falkb

Replying to anonymous:

So this needs to be fixed in plug-in code right?

Yes, you're right. And it shouldn't be that hard for ChrisNelson with the given hint.

comment:11 in reply to: ↑ 10 Changed 3 years ago by ChrisNelson

Replying to falkb:

Replying to anonymous:

So this needs to be fixed in plug-in code right?

Yes, you're right. And it shouldn't be that hard for ChrisNelson with the given hint.

In the next week or so, I plan to reconcile our internal version of the plugin with the one on TH and include community patches and fixes like this. Stay tuned.

comment:12 Changed 3 years ago by rjollos

  • Cc rjollos added

comment:13 in reply to: ↑ description Changed 3 years ago by anonymous

Replying to anonymous:

Hi i have installed Trac jsGantt plugin. I am using .12 trac on RHL5. I can see the chart in firefox and chrome but i cant see the chart in IE 8. Please help. Am i missing sommething?

comment:14 Changed 2 years ago by ChrisNelson

(In [10833]) Handle Microsoft-specific event registration. Refs #9284.

comment:15 follow-ups: Changed 2 years ago by ChrisNelson

  • Status changed from new to assigned

This still works for me in FF. Please let me know if IE is happy.

comment:16 in reply to: ↑ 15 Changed 2 years ago by falkb

Replying to ChrisNelson:

This still works for me in FF. Please let me know if IE is happy.

Works here with IE 8 now. :-)

comment:17 Changed 2 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:18 in reply to: ↑ 15 Changed 2 years ago by anonymous

Replying to ChrisNelson:

This still works for me in FF. Please let me know if IE is happy.

Awesome...works in IE as well.. Thank you so much !

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from ChrisNelson. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.