Modify

Opened 3 years ago

Closed 11 months ago

#9514 closed defect (duplicate)

Error: Macro TracJSGanttChart(sample=1) failed

Reported by: kostanos@… Owned by: malsmith
Priority: normal Component: TracJsGanttPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I installed the plugin, and got this error in the place of inserting sample and any other gantt

[[TracJSGanttChart(sample=1)]]

Error message:

Error: Macro TracJSGanttChart(sample=1) failed
%d format: a number is required, not unicode

I found the similar but different issue: #9124

Here is my log trace:

2011-11-02 17:22:26,205 Trac[formatter] ERROR: Macro TracJSGanttChart(sample=1) failed:
Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.2-py2.6.egg/trac/wiki/formatter.py", line 717, in _macro_formatter
    return macro.process(args, in_paragraph=True)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.2-py2.6.egg/trac/wiki/formatter.py", line 304, in process
    text = self.processor(text)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.2-py2.6.egg/trac/wiki/formatter.py", line 291, in _macro_processor
    text)
  File "/usr/local/lib/python2.6/dist-packages/Trac_jsGantt-0.9_r10837-py2.6.egg/tracjsgantt/tracjsgantt.py", line 1109, in expand_macro
    chart += self._begin_gantt(options)
  File "/usr/local/lib/python2.6/dist-packages/Trac_jsGantt-0.9_r10837-py2.6.egg/tracjsgantt/tracjsgantt.py", line 234, in _begin_gantt
    (javascript_quote(format), showdep)
TypeError: %d format: a number is required, not unicode

Attachments (0)

Change History (2)

comment:1 Changed 11 months ago by rjollos

  • Component changed from GanttChartPlugin to TracJsGanttPlugin

comment:2 Changed 11 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9551.

Add Comment

Modify Ticket

Action
as closed The owner will remain malsmith.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.