Modify

Opened 3 years ago

Closed 21 months ago

#9719 closed defect (fixed)

Regression: WikiTicketCalendar doesn't show multiple milestones per day.

Reported by: hasienda Owned by: hasienda
Priority: normal Component: WikiCalendarMacro
Severity: normal Keywords: milestone
Cc: Trac Release: 0.11

Description

As ilewismsl reported in a comment to #9703, the compact calendar presentation is limited to showing a maximum of one milestone per day, while it should certainly show all milestones with due_date set to a given day.

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by hasienda

  • Summary changed from Regression: WikiCalendar doesn't show multiple milstones per day. to Regression: WikiCalendar doesn't show multiple milestones per day.

comment:2 Changed 3 years ago by hasienda

  • Status changed from new to assigned
  • Summary changed from Regression: WikiCalendar doesn't show multiple milestones per day. to Regression: WikiTicketCalendar doesn't show multiple milestones per day.

From the WikiCalendarMacro page: "...and days with Milestones are marked in bold."

But your assertion is still valid for WikiTicketCalendarMacro. I can reproduce and will fix this for sure.

Thank you again for the report. Would be perfect, if you could test upcoming changes and report back again about your experience.

comment:3 follow-up: Changed 3 years ago by hasienda

(In [11172]) WikiCalendarMacro: Restore ability to display multiple milestones per day, refs #9719.

Obviously code has been simplyfied too much in the big macro merge [10203]. Thanks to ilewismsl for spotting this 8 months old regression.

comment:4 in reply to: ↑ 3 Changed 3 years ago by ilewismsl

Replying to hasienda:

(In [11172]) WikiCalendarMacro: Restore ability to display multiple milestones per day

Thank you for the update. I loaded the latest trunk and I am now able to retire the old WikiTicketCalendarMacro. Except for the relative links to pages everything seems fine, at least so far.

comment:5 Changed 3 years ago by hasienda

Thanks, appreciate the positive response.

Meanwhile the other issue you mentioned should really have been resolved as well. Resolution of relative wiki paths works even better now due to rather generic code borrowed from Trac core.

comment:6 Changed 21 months ago by hasienda

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [12842]) WikiCalendarMacro: Releasing current, tested macro package as final product, closes #64, #578, #6636, #7564, #7653, #8818, #9568, #9718 and #9719.

After a long time one of the oldest Trac hacks (see changeset [53]) is united with its ambitious fork WikiTicketCalendarMacro for convenience. While maintaining separate wiki pages for both macros, upstream development continues together in the source:wikicalendarmacro/trunk branch.

Add Comment

Modify Ticket

Action
as closed The owner will remain hasienda.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.