Changes between Initial Version and Version 2 of Ticket #9743


Ignore:
Timestamp:
Oct 1, 2012 2:05:55 AM (2 years ago)
Author:
rjollos
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #9743

    • Property Status changed from new to closed
    • Property Resolution changed from to fixed
  • Ticket #9743 – Description

    initial v2  
    11If you reference a ticket whose latest modification is not a comment, the plugin will fail with an error.  To reproduce: 
    22 
    3 1. Create a ticket 
    4 1. Comment on that ticket 
    5 1. Change the ticket's priority from major to minor 
    6 1. Create a second ticket 
    7 1. Comment on the second ticket with a reference to the first ticket 
     3 1. Create a ticket 
     4 1. Comment on that ticket 
     5 1. Change the ticket's priority from major to minor 
     6 1. Create a second ticket 
     7 1. Comment on the second ticket with a reference to the first ticket 
    88 
    99The plugin will fail with a `ValueError`, because it assumes that the latest changelog entry in `t.get_changelog()` will always be a comment. 
     
    1818}}} 
    1919 
    20 I haven't tested against earlier versions of Trac to see if it's a new issue.  It does seem to be related to #9008 -- and a commenter (http://trac-hacks.org/ticket/9008#comment:1) posted a traceback there, against trac 0.12.2, which is functionally identical to the traceback I'm seeing. 
     20I haven't tested against earlier versions of Trac to see if it's a new issue.  It does seem to be related to #9008 -- and a commenter ([/ticket/9008#comment:1 comment:1:ticket:9008]) posted a traceback there, against trac 0.12.2, which is functionally identical to the traceback I'm seeing. 
    2121 
    2222The following patch fixes the problem by filtering the referenced-ticket's changelog to only include comments: