Modify

Opened 3 years ago

Closed 3 years ago

#9844 closed defect (fixed)

Module does not support same version of Python as current Trac

Reported by: dannysauer Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

When installing the plugin, I get an error saying: TimingAndEstimationPlugin requires Python 2.5 or later

However, the wiki page indicates that Trac back to 0.10 is supported. The current stable version of Trac is 0.12, which also only requires Python 2.4. Python 2.4 is the only version of Python supported by RHEL 5.x (and thus CentOS 5.x, for those who'd like to set up a test machine), which is itself supported by RedHat until 2017 - and I unfortunately can't update this server to 6.x yet.

I agree that it's old, but I was using plugin version 1.0.8 just fine on Python 2.4. I guess I don't *need* the latest code, but I was hoping to get a fix for the missing Billing URL which puts sad 404 errors in my web server log. :)

If I can't get 2.4 supported, is there any chance I can get an indication of what the last subversion revision which supports 2.4 is?

Attachments (0)

Change History (7)

comment:1 follow-up: Changed 3 years ago by rjollos

  • Description modified (diff)

comment:2 in reply to: ↑ 1 ; follow-up: Changed 3 years ago by dannysauer

Thanks for fixing the link; I'll go ahead and add a comment to help people who happen to search the web using the actual error string. ;)

TimingAndEstimation requires Python 2.5 or later

comment:3 in reply to: ↑ 2 Changed 3 years ago by rjollos

Replying to dannysauer:

Thanks for fixing the link; I'll go ahead and add a comment to help people who happen to search the web using the actual error string. ;)

Oh, right. Makes sense, I shouldn't have changed that.

comment:4 Changed 3 years ago by bobbysmith007

This has been VERY problematic in the last month where as I had not heard any trouble with this before. As such I may end up writing a patch to make this work in python2.4 (even though it is not direct for me to install it; ie it doesnt appear in aptitude on ubuntu server 11.10 by default).

#9793 is what prompted the error you are running into. It was requested that I add that error to the setup file. To bypass the error you can simply change this line at the top of the setup.py file to be 2.4 or whatever and probably bypass the version check all together.

- min_python = (2, 5)
+ min_python = (2, 4)

The problem (#9793) seemed to be that strptime changed location between py2.4 and py2.5. If you post a patch resolving the problem before I get to it, I will gladly apply it.

comment:5 Changed 3 years ago by bobbysmith007

(In [11383]) T&E Bug fixes

  • remove python version requirements
  • fix date parsing (again)
  • fix db_table_exists (again)

re #9612 and #9793 and #9844 and #9901

comment:6 Changed 3 years ago by bobbysmith007

(In [11384]) T&E Bug fixes (version 1.2.7)

  • Enforce customizable permission on the billing/management page
  • remove python version requirements
  • fix date parsing (again)
  • fix db_table_exists (again)

re #9612 and #9793 and #9844 and #9901

comment:7 Changed 3 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from new to closed

It seemed like there was a value in attempting to get this to run in python 2.4. I have made an attempt at changing the code so that it should work in 2.4 on.

I cant easily run 2.4 , but I have replaced the offending function, so it should hopefully work. Please report any bugs you might find.

I also removed any code that tried to enforce python version requirements

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.