Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9897 closed defect (fixed)

ProjectPlan does not load with Trac > 0.12

Reported by: adam.dorsey@… Owned by: anbo
Priority: normal Component: ProjectPlanPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I get the following error in trac.log when trying to load ProjectPlan on a Trac 0.12.2 instance:

2012-03-12 15:43:56,529 Trac[loader] ERROR: Skipping "ProjectPlan 0.91.2": (version conflict "VersionConflict: (Trac 0.12.2 (/usr/lib/python2.6/site-packages
/Trac-0.12.2-py2.6.egg), Requirement.parse('Trac>=0.11,<=0.12'))")

I don't know if there is an actual reason the plugin can't run on newer versions of Trac 0.12; I'll try manually changing the version string and find out.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

It appears that changing that line in EGG-INFO/requires.txt to

Trac >=0.11, <=0.12.2

lets the plugin run. I can see no immediate issues.

comment:2 follow-up: Changed 3 years ago by anbo

  • Resolution set to fixed
  • Status changed from new to closed

(In [11392]) changed the requires Trac version, now all 0.12.* release are accepted (thanks to adam.dorsey@… for the hint)
fixes #9897

comment:3 in reply to: ↑ 2 Changed 3 years ago by rjollos

Replying to anbo:

(In [11392]) changed the requires Trac version, now all 0.12.* release are accepted (thanks to adam.dorsey@… for the hint)
fixes #9897

There is some discussion in #9800 regarding the use of install_requires that might be of interest to you.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.